Announcement

Collapse
No announcement yet.

Database connection error on install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database connection error on install

    Hey, I'm getting the following error on install..

    Warning: Supplied argument is not a valid MySQL-Link resource in /home/webadmin/fighterops.com/html/forum/includes/db_mysql.php on line 140
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

    I have created a database and a user within that database, and supplied those correctly to the config.php file. Is there something I'm doing wrong?

    Here is my config.php file..
    // ****** DATABASE SERVER NAME ******
    // This is the hostname or IP address of the database server.
    // It is in the format HOST:PORT. If no PORT is specified, 3306 is used.
    // If you are unsure of what to put here, leave it at the default value.
    $servername = 'http://www.fighterops.com';

    // ****** DATABASE USERNAME & PASSWORD ******
    // This is the username and password you use to access MySQL.
    // These must be obtained through your webhost.
    $dbusername = 'admin';
    $dbpassword = '****';

    // ****** DATABASE NAME ******
    // This is the name of the database where your vBulletin will be located.
    // This must be created by your webhost.
    $dbname = 'forum';

  • #2
    Turns out it was only because of the messed up configuration of the server. Nothing is where it should be so I just had to mess around and point the install to the correct, though strange, location of the database server..

    Comment


    • #3
      $servername thats not a URL its the database server host. You should change this to localhost and try.

      How did you create the database? Do you have root access or are you using a hosting panel?
      Scott MacVicar

      My Blog | Twitter

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X