Announcement

Collapse
No announcement yet.

One guest won't show IP #

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Yep will send ASAP.

    Comment


    • #17
      problem in your code modification and i've fixed it. I suspect your behind a load balancer or something similar thats masking the true IP.

      So i'm after someone who is having this problem still that hasn't modified the IP detection code.
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #18
        Thanks for the help.

        Strange that the IP's were only missing for users behind a proxy though.

        Comment


        • #19
          Well I uploaded the file you sent, in ASCII mode, and it is still happening. Although not as frequently.

          Comment


          • #20
            Scott, you could alter his code to try and see if ALT_IP is showing up? It is the IP (at times) behind the proxy. Might be worth a try.

            Comment


            • #21
              This has also been happening to me....I will grab the sessions table if I see it happen today.
              My Live vB5 Site - NZEating.com
              vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

              Comment


              • #22
                MegaHertz can you send me a link to your phpinfo i think your admin might have picked the wrong variable to use.
                Scott MacVicar

                My Blog | Twitter

                Comment


                • #23
                  Sent via email.

                  Comment


                  • #24
                    It only happend to me once but if I see it again I will take a copy of sessions table I did take a pic but thats just cuz it shocked me
                    To be or not to be... Where the hell is the question????
                    My psychiatrist told me I was crazy and I said I want a second opinion. He said okay, you're ugly too

                    Live vBulletin 4.2.0 Multilingual * Alpha/Beta vB 4 - vB 5 Tier 1A
                    CentOS 6.2 - Apache:2.2.15(Apache2Handler) - PHP:5.3.3 - MySQL:5.1.61
                    Xampp/Win-XP - Apache v2.2.21(Apache2Handler) - PHP:5.3.8 - MySQL:5.5.16

                    Comment


                    • #25
                      MegaHertz, You dont need that code that was added to init.php $_SERVER['REMOTE_ADDR'] contains the correct value.

                      Maybe at one point you were behind a load balancer or a cache server but not any more.
                      Scott MacVicar

                      My Blog | Twitter

                      Comment


                      • #26
                        OK, I removed the code and here is what happens (see screenshot). This is what led to the modification being installed, and also to us being locked out of our forum after the upgrade to vB 3.01 (see this thread).
                        Attached Files
                        Last edited by MegaHertz; Tue 8 Jun '04, 6:59pm.

                        Comment


                        • #27
                          I encountered this earlier as well. It was a single guest that showed no IP. It has only happened this once. I have since done a repai/optimize on the database. If I see it again, I'll capture the db state in an sql dump for you. Would that help?

                          EDIT: I haven't modified the init.php code at all, not altered any table structures. I run my own server, and am behind a router using a typical class c internal range.
                          Last edited by RagingPenguin; Tue 8 Jun '04, 7:20pm.
                          House of Night Forums - An online House of Night roleplaying community,

                          Comment


                          • #28
                            ah wait nm you can put it back.

                            I just realised the phpinfo page I looked at had the REMOTE_ADDR already modified since it loaded init.php first.
                            Scott MacVicar

                            My Blog | Twitter

                            Comment


                            • #29
                              Already done.

                              Comment


                              • #30
                                Scott do you still want me to send you a copy of seesion.sql? I just saw another guest without an IP on a second board that I am a tech admin on when the owner alerted me about the IPless guest I took a copy of session.sql
                                To be or not to be... Where the hell is the question????
                                My psychiatrist told me I was crazy and I said I want a second opinion. He said okay, you're ugly too

                                Live vBulletin 4.2.0 Multilingual * Alpha/Beta vB 4 - vB 5 Tier 1A
                                CentOS 6.2 - Apache:2.2.15(Apache2Handler) - PHP:5.3.3 - MySQL:5.1.61
                                Xampp/Win-XP - Apache v2.2.21(Apache2Handler) - PHP:5.3.8 - MySQL:5.5.16

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X