Announcement

Collapse
No announcement yet.

Flakey behaviour with templates and "revert"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Flakey behaviour with templates and "revert"

    I've been messing around editing one of the templates that was created for me when I migrated from vB2 to vB3. This template is part of a style that has no parent - e.g., it is not a child of the vB Default.

    When editing a template, I click "Save", and it then tells me it changed the template, then it redisplayes the template. However when it redisplays, the changes I made are not there!

    So I make the change again, do the same thing, and its still not there.

    Then I click on "revert", save it, and suddenly the last change I made before the "revert" shows up! (It never reverts to the default.)

    Is this because I'm editing a style that isn't inherited from the vB Default?
    Or is something broken?

  • #2
    I think your having some issues with browser cache gary, what browser are you using to look into the admincp ?

    Comment


    • #3
      IE 6.0.

      Haven't had any other indications of caching issues.

      Comment


      • #4
        what is Open IE >tools > internet Options > settings > Check for newer versions of stored pages, set to ?

        Comment


        • #5
          "Automatically"

          Comment


          • #6
            Actually...

            it isn't a caching issue. If it were a caching issue, then the changes would have been made in the database - I simply would be seeing an older version of the rendered page.

            That ain't happening.

            The changes are not being made in the database. They sometimes are, and they sometimes aren't. And when I check "revert", it sometimes does nothing, and sometimes just reverts to my last change, but it no longer reverts to the vB default (although it did earlier today.)

            Its flakey. It does not seem to behave the same way twice.

            Comment


            • #7
              Have you modifed any of the files? The only thing i can think of is that its either a cacheing issue or youve hacked a file abit wrongly.

              If you want could you send me a pm with an admin login and i will see if i can replicate this problem.

              Comment


              • #8
                I haven't hacked it at all, and I'm 100% certain it isn't a caching issue.

                PM Sent. Thanks!

                Comment


                • #9
                  The templates imported from vB2 are purely for reference and I dont believe you can edit them, though i'd have to go read through the code for that section.
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    I was able to edit, save, then view the changed template, then revert it. with out any problems.

                    Comment


                    • #11
                      This is outta control

                      Its flakey - really.

                      It seems as though it allows x number of edits to a particular template. Further edits don't "take". Then I need to do a couple of "reverts", and after a couple of those, I can edit it again. Sometimes 1 "revert", sometimes more. Sometimes "revert" goes back to the last edit. Sometimes it goes back a few edits. If I do a *lot* of reverts, eventually it goes back to the forum default.

                      It seems to behave as though it saves a "history" of edits. Almost like a stack.

                      I'm really getting frustrated with this! Every time I edit a template more than a few times, I get into this situation, and once it gets there, editing is a crap shoot.

                      It ain't a caching issue!!!


                      More info: I just did some tests.

                      1) Created a brandy new Style.
                      2) Edited the header. Worked fine.
                      3) Edited the header a second time. Worked fine.
                      4) Edited the header a third time. Edits did not show up.
                      5) Reverted. Went back to the state it was after the first edit.
                      6) Edited the header again. Edits did not show up.
                      7) Reverted. Went to the state it *should* have been after the third edit!!

                      This is too screwy.
                      Last edited by Gary Fischman; Wed 9 Jun '04, 6:28pm.

                      Comment


                      • #12
                        As ive stated in the PM i can find nothing wrong on my end, i edited the new style and its templates multiple times with no problems.

                        Comment


                        • #13
                          Verified that this problem is due to a failure to create the UNIQUE KEY on the template table correctly.

                          To identify this problem, run
                          mysqldump --no-data databasename tableprefixtemplate

                          Look towards the end of the output, and you should see this:
                          Code:
                          UNIQUE KEY title (title,styleid)
                          This is correct.

                          However, if the word UNIQUE is missing, like this:
                          Code:
                          KEY title (title,styleid)
                          ...then the unique key was not created properly and the table will need to be fixed manually.

                          It is this that causes the unpredictable edit/revert behavior.

                          Comment


                          • #14
                            Im confused why i didnt get the error O.o

                            Comment


                            • #15
                              If you tried it on your own boards, the chances are that you don't have the problem. I've seen this issue about 5 times in total since the early betas of vBulletin 3, and we've never found out why some people's installations have this problem.

                              Anyway, I've posted a step-by-step guide to fixing the problem for everyone else who has it here:
                              http://www.vbulletin.com/forum/showthread.php?t=107653

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X