Announcement

Collapse
No announcement yet.

MySQL log errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL log errors

    I just installed vBulletin on my server (FreeBSD 4_9) and am now getting some MYSQL (4.0.20) errors in my log directly caused by vBulletin. I know this because the db 'crechat_com' is used by vBulletin. Anyone know what's going on here and possibly how to fix it?

    040602 15:01:05 Aborted connection 1 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 16:05:09 Aborted connection 51 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:21:03 Aborted connection 52 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:21:05 Aborted connection 53 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:22:16 Aborted connection 54 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:25:11 Aborted connection 56 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:28:35 Aborted connection 57 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040603 18:29:35 Aborted connection 55 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040604 15:28:12 Aborted connection 59 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040604 15:28:12 Aborted connection 60 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040604 15:30:34 Aborted connection 62 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040604 15:30:34 Aborted connection 61 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040605 13:45:33 Aborted connection 91 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040605 13:45:33 Aborted connection 92 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040607 0:27:58 Aborted connection 109 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)
    040607 0:27:58 Aborted connection 110 to db: 'crechat_com' user: 'mysql0' host: `localhost' (Got timeout reading communication packets)

    According to some FreeBSD/MYSQL pros, some ideas are:

    >The manual in the Docs directory lists several possible reason for the
    >Abort messages. I think the client not shutting down correctly, or taking
    >too long to shut down or the threads interrupt reasons make the most sense.

    Additionally, here is a direct link to the MYSQL page defining this error:

    http://dev.mysql.com/doc/mysql/en/Co...on_errors.html

    and

    http://lists.mysql.com/mysql/14440

    Thanks for the advice, this is the last problem I need to fix before I colo my box.

  • #2
    Is the mysql server and apache server the same or are they on differnt systems ?

    Comment


    • #3
      Originally posted by Zachery
      Is the mysql server and apache server the same or are they on differnt systems ?
      Yes, the mysql server and apache server are on the same box, hence the 'localhost' in the error logs. I'm using the 'large' MYSQL config file with a startup command of:

      mysqld_safe --user=mysql --bind-address=127.0.0.1 --log-error=/home/wwwroot/_log/error_mysql.log --skip-thread-priority &

      The only other application using mysql at this point is Listmail (www.listmailpro.com).

      You can see another discussion thread about this exact same error (which I also started) here:

      http://www.bsdforums.org/forums/show...threadid=22480

      Thanks.

      Comment


      • #4
        You might want to ask Eva2000 about a server configuration

        Comment


        • #5
          Originally posted by Zachery
          You might want to ask Eva2000 about a server configuration
          Who is Eva2000? This is clearly an issue about the way vBulletin is communicating with MYSQL. I really need your help on this because my shipping deadline is in two days. I've provided a lot of info here, can you please tell me what vBulletin might be doing and how to fix it? My message board has ZERO posters at this point, so that's not the problem.

          Comment


          • #6
            Eva2000 is George, he appears to have guru knowledge of MySQL

            Comment


            • #7
              vBulletin does not communicate with MySQL directly. Its all done through the MySQL functions in PHP.

              Do you have persistent connections enabled?
              Its caused by the mysql timeout being reached and mysql kills the process.
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                Heh, I still don't know who George is. I spent three hours exchanging emails with your tech support trying to retrieve my password for your forums... please, I need to have some answers and spend my time on other projects. Can you please tell me where to begin fixing this problem?

                What I know is this:

                1. The problem started after installing vBulletin.
                2. The db that is reporting the problem is reserved for vBulletin.
                3. It appears to be a vBulletin issue.
                4. This is the vBulletin support chat board.

                Can ya help me?

                Comment


                • #9
                  Its not an error, its a warning message and its not something we can fix. If its a bug its a bug with PHP the scripting language which vBulletin is written in.

                  It means that a connection to MySQL timed out and wasn't closed by the apache process presumably as persistent connections are turned on or some other configuration problem.

                  You can check if they are off by opening includes/config.php and make sure
                  $usepconnect = 0;
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    Okay, how do I contact George?

                    Comment


                    • #11
                      George is in australia and only provides support via the forums. I'd try sending him a private message http://www.vbulletin.com/forum/priva...do=newpm&u=245

                      Did you check to see if persistent connections was off?
                      Scott MacVicar

                      My Blog | Twitter

                      Comment


                      • #12
                        I had persistent connections set to ON. I just turned them off. Do I need to do anything to make the change active? I'm thinking not, but...

                        Comment


                        • #13
                          Nope you should see it finish once any remaining connections have timed out.
                          Scott MacVicar

                          My Blog | Twitter

                          Comment


                          • #14
                            Originally posted by JeffBeaubien
                            Okay, how do I contact George?
                            someone called my name

                            can you post the contents of your /etc/my.cnf file ? if you don't have one can you post the output of the command (as root user in ssh telnet)

                            mysqladmin -u root -p variables
                            copy and paste output here

                            lately there's been alot of people setting their mysql wait_timeout at too low values i.e. 60-100 seconds! or max_allowed_packets may need increasing

                            Other possible reasons are outlined at http://dev.mysql.com/doc/mysql/en/Co...on_errors.html

                            Turning off pconnects can help too
                            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                            :: Nginx SPDY SSL - World Flags Demo [video results]
                            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                            Comment


                            • #15
                              Hiya George, I turned off the pconnects in the includes/config.php file yesterday and am going to check it this morning (just checked it and haven't got any of those warnings in the past 6 hours). Per your request, here is my my.conf file...

                              [client]
                              #password = your_password
                              port = 3306
                              socket = /tmp/mysql.sock

                              # Here follows entries for some specific programs

                              # The MySQL server
                              [mysqld]
                              port = 3306
                              socket = /tmp/mysql.sock
                              skip-locking
                              key_buffer = 256M
                              max_allowed_packet = 1M
                              table_cache = 256
                              sort_buffer_size = 2M
                              read_buffer_size = 2M
                              myisam_sort_buffer_size = 64M
                              thread_cache = 8
                              query_cache_size= 16M
                              # Try number of CPU's*2 for thread_concurrency
                              thread_concurrency = 8

                              # Replication Master Server (default)
                              # binary logging is required for replication
                              log-bin

                              # required unique id between 1 and 2^32 - 1
                              # defaults to 1 if master-host is not set
                              # but will not function as a master if omitted
                              server-id = 1


                              [mysqldump]
                              quick
                              max_allowed_packet = 16M

                              [mysql]
                              no-auto-rehash
                              # Remove the next comment character if you are not familiar with SQL
                              #safe-updates

                              [isamchk]
                              key_buffer = 128M
                              sort_buffer_size = 128M
                              read_buffer = 2M
                              write_buffer = 2M

                              [myisamchk]
                              key_buffer = 128M
                              sort_buffer_size = 128M
                              read_buffer = 2M
                              write_buffer = 2M

                              [mysqlhotcopy]
                              interactive-timeout

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X