Announcement

Collapse
No announcement yet.

Korean Encoding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Korean Encoding

    Hello. My vB 3.0.1 forums have a bit of problem when I type something in Korean in my posts.

    Most characters, show up, but some do not.

    For example, "서" which shows up on this forum, will not show up on my forums. On my forums, it will show it as "?"

    Does anyone know the fix for this?


    Thank you

  • #2
    What charset are you using?

    Comment


    • #3
      What do you mean charset?

      If you're talking about what the forum maybe using about the unicode or something, I'm not sure, but it should be at default since I've never modified anything related to languages.

      Comment


      • #4
        AdminCP > Langauge and Phrases > Language Manager > Edit language > Set the character set to whatever set you need UTF-8 may be correct for your language.

        Comment


        • #5
          It may need to be one of these:

          Korean:
          charset=ks_c_5601-1987

          Korean (EUC):
          charset=euc-kr

          Korean (ISO):
          charset=iso-2022-kr

          Korean (Johab):
          charset=Johab

          Korean (Mac):
          charset=x-mac-korean

          From: http://a4esl.org/c/charset.html
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Do you mean Edit Settings Zachery? Because I cannot find Edit Language.

            Also, I tried those charsets in the Language Code and HTML Character Set, but they did not work. Am I putting them in the right place?

            Comment


            • #7
              Did you create a new Korean Language Pack? And which settings did you try exactly?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I don't need to create a whole Korean Language Pack do I?

                I'm only have problems with couple letters like 서, 화, 난.

                I'm not trying to change the whole board into Korean. Just the ability to type Korean posts and don't have any characters come up as ?.

                Comment


                • #9
                  I believe this is a function of the browser and/or PC you are using. You need to enable this language support on your PC.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Steve, I don't believe that that is the problem as that is what happens on all the computers in school and all my friend's computers. We can all see these letters fine in vBulletin.com, but not our forum.

                    Could this maybe be because the server does not support all korean characters?

                    Comment


                    • #11
                      Um.. hello?

                      Any help here?

                      Comment


                      • #12
                        If said computers at school do not have the langauge installed they would not be able to see the characters.

                        Comment


                        • #13
                          They do have Korean Language support for Korean, Chinese, and Japanese as it's an International school located in south east China and over 60% of the school population is Korean.

                          Any other possibilities that this might not work?

                          Comment


                          • #14
                            Not really sure why this isnt working for them :/

                            Do you have any other languages installed besides the default?

                            Comment


                            • #15
                              I'm still using VB2 and I had to delete codes below in functions.php in VB2
                              Maybe you also need to try simular things out in VB3.
                              Code:
                              $text = str_replace(chr(173), '_', $text); 
                              $text = str_replace(chr(160), '_', $text);

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X