No announcement yet.

Image thumbnails?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Image thumbnails?

    I have gdlib version 2.0.22 the AdminCP server settings and optimizations page says "bundled (2.0.22 compatible)"
    "rpm -qa |grep gd" says 1.8.4 (not gif-compatible) but I installed version 2.0.22 (also not gif-compatible) when I installed the webserver.

    Anyhow, to the point..
    My board is generating thumbnails of GIFs and PNGs.. but wont do JPEGs (I do have jpeg-6b installed)

    I dont understand how its doing gifs at all.. or why its not doing jpegs..
    Help understanding either would be very nice.

    After checking the phpinfo(); I see that I have gif reading support, just cant write gifs.. So that explains that, its writing out as PNGs not gifs..
    So still wondering why it wont make thumbnails of jpegs..

    Somebody help please?
    New Member
    Last edited by liquidx; Wed 19 May '04, 1:24am. Reason: Did more research

  • #2
    Did you make sure when you compiled you had the correct path to the libs?


    • #3
      Originally posted by Zachery
      Did you make sure when you compiled you had the correct path to the libs?
      Turns out this was the problem.

      It had me baffled for errors because php's configure was saying it found the libs and it even compiled gd_jpeg.lo just fine, but the support was still not enabled.

      After specifying the directory manually instead of just --with-jpeg-dir (which without parameters detected them in /usr/lib, which they were not) it worked just fine.


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.