Announcement

Collapse
No announcement yet.

Email Issues with vb3.0.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Issues with vb3.0.0

    Email is not working. I am running vb3.0.0 on a windows server.

    I have read through all the email problem threads and have tried a few of the solutions mentioned. My email is still not working and the diagnostic is giving:

    The mailing function returned an error while trying to send the mail.The following errors were outputted by PHP when attempting to send mail:


    Warning: mail(): Failed to connect to mailserver at "157.198.239.55" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\Program Files\Apache Group\Apache2\htdocs\forums\admincp\diagnostic.php on line 279
    Check your mail server to ensure it is configured correctly to allow PHP to send mail from it. You should also check your mail server's error log for more diagnostic information.
    In April I upgraded from vb2.2.7 to vb3.0.0. After upgrading email was working. I had problems with the subscriptions to forums, and support had me upgrade my php to v4.3.6. It seems since then, that the email has not been working.

    My php.ini is in the C:\WINNT and has the following email function text:

    [mail function]

    ;WIN32

    SMTP = xxx.198.239.55 ; for Win32 Only

    sendmail_from = [email protected] ; for Win32 Only

    ;WIN32

    ;sendmail_from = [email protected]

    ; For Unix only. You may supply arguments as well (default: "sendmail -t -I").

    ;sendmail_path =

    Is there a fix to this that I am overlooking? What other files are involved with emailing that I might have goobed?

    Thanks for any and all help with this!

    John Richter

  • #2
    Is the mail server on a different physical server? If not, then change SMTP to 'localhost'. If it is, then that server is not configured to accept SMTP connections from your server. You will need to contact the server admin for help with this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks

      Steve:

      Thanks for the info! I figured out that the email server is different than the one I had listed. I found the correct one and changed the php.ini. The test worked now!

      Thanks again,

      JR

      Comment


      • #4
        Kind of Fixed

        Steve,

        Your previous bit of info did help me troubleshoot the issue. I located the correct email server (I think) and the diagnostic test sent the email (I know because it sent it to me). BUT the following error occurred in the diagnostic test (with the -f parameter turned off):

        Fatal error: Maximum execution time of 30 seconds exceeded in c:\Program Files\Apache Group\Apache2\htdocs\forums\admincp\diagnostic.php on line 283

        And with the -f parameter turned ON:

        Fatal error: Maximum execution time of 30 seconds exceeded in c:\Program Files\Apache Group\Apache2\htdocs\forums\admincp\diagnostic.php on line 279

        Fatal error: Maximum execution time of 30 seconds exceeded in c:\Program Files\Apache Group\Apache2\htdocs\forums\includes\functions.php on line 466

        In both cases the email goes through. When I try to send an email to multiple users I get:

        Emailing
        Showing Users 1 to 4 of 4


        163 - John Richter ....


        And the other users never come up.

        Any ideas?

        Thanks for your help on this one!

        John Richter

        Comment


        • #5
          I found the Problem

          Before anyone spends time responding to my previous issue, I have found the fix. The mail server that I was pointing to was an old server. I found the current one and now it works with no errors.

          JR

          Comment

          Loading...
          Working...
          X