Announcement

Collapse
No announcement yet.

Announcements block registered users?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Announcements block registered users?

    I want my announcements to only be viewable by guests and not of registered users. Can someone tell me how to do this? I tried putting this <if condition="$bbuserinfo['usergroupid'] != 2">
    in the announcements template, but did not work

    Thanks!!

    .
    Last edited by streetjob; Sat 21 Aug '04, 1:48pm. Reason: Testing edit timeframe

  • #2
    Use this conditional:

    HTML Code:
    <if condition="!$bbuserinfo['userid']">text here</if>
    Bugdar: PHP bug tracking software that is beautiful, fast, and robust.

    Comment


    • #3
      Im sorry Daemon, but I need this spelled out clearly for me. Can you tell me where to put this exactly? I am still a newbie, thanks!

      Comment


      • #4
        Go to your:

        Admin CP -> Styles & Templates -> Style Manager -> « » -> Forum Display Templates -> FORUMDISPLAY

        Find $announcebits and surround it with your condition (which is the correct condition, by the way):

        Code:
        <if condition="$bbuserinfo['usergroupid'] != 2">
        $announcebits
        </if>
        This will hide the announcements on forumdisplay pages.

        And just in case a registered user loads the direct link to an announcement, you can hide the contents of the announcement by going to your:

        Admin CP -> Styles & Templates -> Style Manager -> « » -> announcement

        Do the same thing... surround the $announcebits variable with your condition.
        Last edited by Jake Bunce; Tue 11 May '04, 7:50pm.

        Comment


        • #5
          Last post edited. The last direction was wrong.

          Comment


          • #6
            Hey Jake,

            Thanks a bunch! Works great and it makes sense too. Also, thanks for the detailed instructions!

            Comment


            • #7
              Originally posted by Jake Bunce
              Last post edited. The last direction was wrong.
              Actually this did work, what you originally stated in the forumdisplay!

              Comment


              • #8
                Originally posted by streetjob
                Actually this did work, what you originally stated in the forumdisplay!
                Yeah, that part was correct to begin with. It's the "direct linking" part that was wrong... I had the wrong template.

                Comment

                Loading...
                Working...
                X