Announcement

Collapse
No announcement yet.

BB Code Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BB Code Problem

    Have a very strange problem that I hope has a simple solution.

    I created apporximately one dozen BB Codes that used to work perfectly in vB 2 but after the upgrade to v3.0.1 they no longer display when used in posts. However they still display properly in the BB Code manager and in the BB Code FAQ.

    They are all tags that can be used to quickly link to other commonly referenced threads on the forum.

    I have attached an image of one of the codes from the code manager.
    Attached Files

  • #2
    What does the [Edit] screen look like? I need to see everything.

    Comment


    • #3
      Here you go.
      Attached Files

      Comment


      • #4
        Ah, you aren't using a {param}.

        I have never been able to get BB codes to work under vB3 without a parameter. I recommend you use a replacement variable instead:

        Admin CP -> Styles & Templates -> Replacement Variable Manager

        Comment


        • #5
          Ok thanks Jake I'll look into it I was hoping to salvage things so that we don't have to go back and fix a lot of posts, but it doesn't look like that will be possible.

          Will it still allow it to appear as a hyperlink?
          Last edited by MegaHertz; Tue 11 May '04, 11:55am.

          Comment


          • #6
            Apparently it will paste the hyperlink but it does not get formatted until after you edit and save the message.

            Comment


            • #7
              Originally posted by MegaHertz
              Ok thanks Jake I'll look into it I was hoping to salvage things so that we don't have to go back and fix a lot of posts, but it doesn't look like that will be possible.
              You should be able to make it so old posts still work. Use [guide][/guide] as the Search for Text, and the link code as the Replace with Text.

              Comment


              • #8
                Originally posted by Jake Bunce
                You should be able to make it so old posts still work. Use [guide][/guide] as the Search for Text, and the link code as the Replace with Text.
                I must be half asleep today where would I preform this search? I have already tried the forum search, but it says no posts exist with that phrase. Which is technically correct since the links have vanished completely and all that is left where they once appeared is empty space.

                Comment

                Loading...
                Working...
                X