Announcement

Collapse
No announcement yet.

vB3 will not send e-mails...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Ah maybe so but its my childish money that I will spend some place else.

    Comment


    • #17
      You certainly have that right. I wish we could have helped more, but honestly as far as I can tell this is a server issue. Best of luck.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        We had the same issure over at ours, and what we found out is that the server had been set up to not allow mail to be sent from user "nobody" and that is how VB tags the header, so.......... we enabled that function and POOF....all of our mails are going out as normal, without rejections.

        Hope this helps!

        The only inherent problem is if folks can hack into any types of other mailers like formmail, then they can send mail out as you since the nobody header is allowed.
        All who wander are not lost.
        - JRR Tolkien -

        Comment


        • #19
          hrm, that sounds reasonable. I'll take a look at that and thanks for the information Illuvatar.

          Originally posted by Illuvatar
          We had the same issure over at ours, and what we found out is that the server had been set up to not allow mail to be sent from user "nobody" and that is how VB tags the header, so.......... we enabled that function and POOF....all of our mails are going out as normal, without rejections.

          Hope this helps!

          The only inherent problem is if folks can hack into any types of other mailers like formmail, then they can send mail out as you since the nobody header is allowed.

          Comment


          • #20
            Hey mate...

            I sent this to ya via pm, but I thought it may prove usefull to others here as well!


            I checked with the folks that manage are server, and this is what they did.

            If you are using WHM/Cpanel for yours, then under WHM you will find under "tweek settings", this option
            Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)
            Uncheck that option and that will allow the mails to go through.

            Regards,

            Illu
            All who wander are not lost.
            - JRR Tolkien -

            Comment


            • #21
              Originally posted by Illuvatar
              We had the same issure over at ours, and what we found out is that the server had been set up to not allow mail to be sent from user "nobody" and that is how VB tags the header,
              Correction - vB does not 'tag' any emails as being from 'nobody'. vB sends a valid return email address (as per your webmaster's emails.) You may be referring to the 'Return-Path' in the header which is added by the server.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                Well... however this get's placed in there
                Received: from nobody by hughes01.wcreplays.com with local (Exim 4.24)
                id 1BHvJz-000458-W6
                Changing this setting if it's checked to unchecked will allow these mails to get through.

                I wanted to post this here, cause when I was going through the same issue, I kept getting and finding "it's a server issue", but no solution on how to fix the isssue.

                Just trying to help the next guy.
                All who wander are not lost.
                - JRR Tolkien -

                Comment


                • #23
                  And that is a very helpful tip too. Thanks!

                  As a test I turned this on in my server's WHM, and sure enough emails immediately started bouncing with the 'unrouteable mail domain' error.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #24
                    Kewlness...........

                    Glad I could help!
                    All who wander are not lost.
                    - JRR Tolkien -

                    Comment


                    • #25
                      I checked it in on our server and it is unchecked so I have no idea how its placing that

                      Received: from nobody by hughes01.wcreplays.com with local (Exim 4.24)
                      id 1BHvJz-000458-W6
                      in the received from.

                      Comment


                      • #26
                        Here is the screen shot of how ours is set.
                        Attached Files

                        Comment


                        • #27
                          When you say nobody do you mean leave it blank as thats not worked?

                          Comment


                          • #28
                            So here I am, looking up keywords: "unrouteable mail domain" becase I am having EXACTLY the same problem. I have had my server for over a year now and suffer NO other email issues, but I just installed vBulletin and now, no mail!

                            My vBulletin mail is being sent out as "nobody", but nobody is disabled in cpanel and it should be. Is there any way to get vb to send from the user name that it's installed under? Has anyone set up and used phpsuexec? Unticking the cpanel nobody tweak took care of the issue, but I'm not convinced that it shouldn't be done a different way.

                            Incidently, many spam sensitive mail systems REJECT mail sent from nobody.

                            EDIT: found more info: http://www.vbulletin.com/forum/archi...hp/t-6247.html

                            EDIT: Installed phpsuexec - all better now!
                            Last edited by oldengine; Thu 11th Nov '04, 1:31pm.

                            Comment


                            • #29
                              ive had this unchecked and it fixed allot of issues but

                              host mx2.hotmail.com [65.54.166.230]: 550 Requested action not taken:
                              mailbox unavailable

                              i still recieve.


                              edit

                              having read that nobody comes up as spam on filters, including hotmail, isnt there a way of registering it as something else like ragezone rather than nobody...........

                              6663 7440KB nobody
                              1694 4867KB ragezone
                              1236 2452KB mailnull
                              42 137KB root
                              is my statistics

                              and in the errors

                              x@hotmail.com R=lookuphost T=remote_smtp:
                              SMTP error from remote mailer after RCPT TO:<[email protected]>:
                              host mx2.hotmail.com [65.54.166.230]: 550 Requested
                              action not taken: mailbox unavailable

                              Advice?
                              Last edited by mentalrz; Sat 23rd Oct '04, 12:48am.

                              Comment


                              • #30
                                well i highly doubt that anyone has the email [email protected] :-p

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X