Announcement

Collapse
No announcement yet.

Searching Error - Allowed memory size of 25165824 bytes exhausted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Searching Error - Allowed memory size of 25165824 bytes exhausted

    To recreate this problem:
    When running certain searches in our forums, we are getting this error:

    Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 35 bytes) in /home/forums/www/search.php on line 946

    http://forums.pcper.com/search.php?

    search for "case" -- you'll get the error.
    serach for "shrout" -- you won't get the error

    I am assuming this is because there are a lot of results for the word "case" on our forums.

    I know one solution is to keep increasing hte amount of memory that PHP is allowed to use, but this seems kind of dangerous to me. Having a single search use up 32 or 64 MB of memory, then having multiple people searching for hte same or similar sized terms at the same time....and you can see how this might eat up the 2 GB of memory my server has pretty quickly.

    Is there no protection or work around for this error in vBulletin's software?

  • #2
    Just saw this was posted on another thread, but that thread's only answer seems to be to up the memory allocation.

    I am looking for a more permanent solution from Jelsoft -- something that won't require me to up the memory limit again when I get 5 million posts instead of 2.5 million.

    Comment


    • #3
      What is your currenty memory limit?

      Comment


      • #4
        It was 24MB but I just upped it to 32MB.

        The same error occurs on the search term "case".

        Comment


        • #5
          Did you make sure you restarted apache?

          Also what is this set to
          AdminCP > vBulletin Options > Message Searching Options > Maximum Search Results to Return?

          Comment


          • #6
            Yep, if you run the search, it now shows 32 megs of memory exhausted.

            Comment


            • #7
              Max search results is set to 250

              Comment


              • #8
                Can you enable public phpinfo in the AdminCP for a few?

                Comment


                • #9
                  yep, done.

                  Comment


                  • #10
                    Your php is terribly out of date, php 4.2.2 is very very buggy, you should try upgrading to 4.3.6.

                    Comment


                    • #11
                      Is this really going to fix anything related to my problem or are you just throwing that out there?

                      Comment


                      • #12
                        I think some of the php 4.2.2 serries bugs was memory leaks

                        Comment


                        • #13
                          This only happens during searches though... ?

                          Comment


                          • #14
                            Honestly, its in your best intrests to upgrade php if its possible.

                            There are tons and tons of bugs assoiated with vBulletin and php 4.2.2

                            Comment


                            • #15
                              Zach is right. There are LOTS of problems with PHP 4.2.2 that affect vB.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X