Announcement

Collapse
No announcement yet.

MySQL Problem. Link-ID = False

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL Problem. Link-ID = False

    Problems with mySQL on this server. Getting error...

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error:

    mysql error number: 0

    Every time my web hosting provider restarts mySQL, it works for a few minutes and then stops working again. Ventures Online claims that this is a vBulletin problem. Here's their response:

    "Matt Johnson
    16-4-2004-09:10 A.M.

    Hello,

    It turns out that the problem is not, in fact, megaman, but rather the fact that you have upgraded to vBulletin v3.0.0. We have seen nothing but problems with this new version. The problem is that the new version of vBulletin is not properly closing it's old connections, so you hit you 45 connection limit very quickly, and then your site starts getting MySQL errors.

    You need to either downgrade to version 2.x, or contact vBulletin to get this problem resolved. Unfortunately, there is nothing we can do in this case as this is your software.
    "

    Comments? Thoughts? Help?!?!

    JR

  • #2
    They are not telling the truth. This is a server issue and the fact that thousands of sites (including this one) are able to run vB3 without this problem is proof of that.

    You can try turning persistent connections off in your config.php:

    PHP Code:
    // ****** PERSISTENT CONNECTIONS ******
    // This option allows you to turn persistent connections to MySQL on or off.
    // The difference in performance is negligible for all but the largest boards.
    // If you are unsure what this should be, leave it off.
    // 0 = Off; 1 = On
    $usepconnect 0
    However if that were the problem as they described it to you, then you would be getting a different error from the 'connect failed' one.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      i just got this one two times today. o looked at the config file and it is set to 0

      here is the hole error. ?

      Database error in vBulletin :

      Link-ID == false, connect failed
      mysql error:

      mysql error number: 0

      Date: Wednesday 21st of April 2004 05:09:09 PM
      Script: http://www.ultimatetesters.com/forums/search.php?do=getnew
      Referer: http://www.ultimatetesters.com/forums/forumdisplay.php?f=7
      IP Address: ************

      any ideas?

      Comment


      • #4
        This means that either the info in config.php is wrong or there is a problem with server.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Did you upgrade using the config.php.new from version 3 or the already existing version 2 config.php?

          Comment


          • #6
            i used the one that i had from v3 beta7 as insructed by the instuction when i upgraded to (gold)

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X