Announcement

Collapse
No announcement yet.

Very useless error msg in Impex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Very useless error msg in Impex

    I keep getting this error in Impex;

    Database error in vBulletin:ImpEx Target 3.0.1:
    Link-ID == false, connect failed
    mysql error:
    mysql error number: 0

    I really don't see how this is suppose to help me in any way.

    I have now tried to install and convert in two different ways. At one point I even created a new database, installed vB3, but when entering Impex I still got that error msg.

    And I can't find any FAQ's on how to actually use the Impex system. Should I install vB3 in the same database that I already use for phpBB2? Or should I create a new database and bring the tables over with the Impex system?

    Any help would be nice

  • #2
    Any sort of help would be nice guys. How to convert a phpbb2 board to vb3 that is. new database? old database? why can't it connect to database when the board itself is up and running?

    I've looked through all the related papers on this and can't find anything.

    Comment


    • #3
      Failed to connect means somthing in your config isnt set correctly, or MySQL is down.

      Comment


      • #4
        Settings? you enter username, server, pass and databasename.. I've entered the same values I've always used, can't see why it would suddently go wrong.

        Why is it the Implex that fails to connect when the board itself is totally up and running fine?

        Comment


        • #5
          Ive not quite sure, i will point jerry to this as soon as i can.

          Comment


          • #6
            Okey. Great.

            Also find it strange that if it's a php file, why it does not have php codes in it, i.e

            targetdatabasetype = mysql

            instead of

            $targetdatabasetype = 'mysql';

            Comment


            • #7
              Okey. Never mind. Problem fixed

              Comment


              • #8
                Originally posted by nepolia
                I keep getting this error in Impex;

                Database error in vBulletin:ImpEx Target 3.0.1:
                Link-ID == false, connect failed
                mysql error:
                mysql error number: 0

                I really don't see how this is suppose to help me in any way.
                It tells you that is couldn't connect to the database, what is useless about that ?

                Originally posted by nepolia
                I have now tried to install and convert in two different ways. At one point I even created a new database, installed vB3, but when entering Impex I still got that error msg.
                So there is something consistantly wrong with the config, did you change the permissions for the new database.

                Originally posted by nepolia
                And I can't find any FAQ's on how to actually use the Impex system. Should I install vB3 in the same database that I already use for phpBB2? Or should I create a new database and bring the tables over with the Impex system?
                Have you read the impex.readme.txt ?
                Last edited by Jerry; Thu 15 Apr '04, 12:34pm.
                I wrote ImpEx.

                Blog | Me

                Comment


                • #9
                  Originally posted by nepolia
                  Okey. Great.

                  Also find it strange that if it's a php file, why it does not have php codes in it, i.e

                  targetdatabasetype = mysql

                  instead of

                  $targetdatabasetype = 'mysql';
                  Thats because its an ini file, its just got php tags wrapping it to stop it being browsed.
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    It's not a PHP file -- it's an INI file. Naming it ImpExConfig.ini would be bad though.

                    I can't comment on why it can't connect to the target DB though -- they use the exact same code. Are you sure you're entering the data (from includes/config.php) correctly?

                    As for the new/old question, it doesn't matter either way really. If you want to remove the phpBB after the import, it's probably easier to do it in seperate DBs as then you can just drop the phpBB database (as opposed to manually removing individual tables).

                    Comment


                    • #11
                      Originally posted by nepolia
                      Okey. Never mind. Problem fixed
                      LOL -- and look at all the responses since then.

                      Comment


                      • #12
                        I bet it was config.
                        I wrote ImpEx.

                        Blog | Me

                        Comment


                        • #13
                          yeah.

                          It got me to the second step in the installation before it crashed again though. couldn't find the right table (was looking for forums.users table, while it should have been forums.phpbb_users), the convertion script wouldn't start again, so basically had to drop the database, install vb3 again and start all over again. this is not supposed to happen is it?

                          Comment


                          • #14
                            Originally posted by nepolia
                            yeah.

                            It got me to the second step in the installation before it crashed again though. couldn't find the right table (was looking for forums.users table, while it should have been forums.phpbb_users), the convertion script wouldn't start again, so basically had to drop the database, install vb3 again and start all over again. this is not supposed to happen is it?
                            So you didn't put the table prefix in is what you are saying ?

                            And even if you did put it in ImpExConfig.php.new did you copy it to ImpExConfig.php ?

                            I've probally done over fifty imports of diffrent phpBB2 boards with it and they went fine for me.
                            I wrote ImpEx.

                            Blog | Me

                            Comment


                            • #15
                              I did put the table prefix on, but now I can't access any of the Impex pages, I just get this message;

                              Database error in vBulletin:ImpEx Source 3.0.1:
                              Invalid SQL:
                              SELECT * FROM phpbb_users
                              LIMIT 0,
                              mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2
                              mysql error number: 1064

                              So, again I have to drop the database, reinstall everything and start all over again.
                              The system does not allow you to make any mistakes and continue after that.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X