Announcement

Collapse
No announcement yet.

issue rebuilding the search index

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • issue rebuilding the search index

    My lights flickered at my house while I was rebuilding the search index (after an upgrade from vb2 to vb3 and now I get this error. I just started with the next number. Is there anything I need to do to fix this? I was 7hrs into the rebuild with about another 100,000 posts to go.

    Database error in vBulletin 3.0.0:

    Invalid SQL:
    REPLACE INTO postindex
    (wordid, postid, score, intitle)
    VALUES
    (1612, 346496, 1, 0), (5877, 346496, 1, 0), (1749, 346496, 1, 0),
    (634, 346496, 2, 0), (1115, 346496, 2, 0), (2399, 346496, 1, 0), (540,
    346496, 1, 0), (396, 346496, 3, 0), (584, 346496, 1, 0), (9724, 346496,
    1, 0), (814, 346496, 1, 0), (179, 346496, 1, 0), (1000, 346496, 1, 0),
    (1280, 346496, 1, 0), (115, 346496, 1, 0), (5153, 346496, 1, 0), (9959,
    346496, 1, 0), (315, 346496, 1, 0), (225, 346496, 2, 0), (9717, 346496,
    1, 0), (2068, 346496, 1, 0), (2069, 346496, 1, 0), (32894, 346496, 1,
    0), (12789, 346496, 1, 0), (299, 346496, 2, 0), (905, 346496, 1, 0),
    (2360, 346496, 1, 0), (2107, 346496, 3, 0), (3759, 346496, 1, 0), (705,
    346496, 1, 0), (18, 346496, 1, 0), (261, 346496, 2, 0), (33, 346496, 1,
    0), (2032, 346496, 1, 0), (2024, 346496, 1, 0), (93, 346496, 1, 0),
    (186, 346496, 1, 0), (189, 346496, 1, 0), (36, 346496, 1, 0), (1303,
    346496, 1, 0), (4068, 346496, 1, 0), (53, 346496, 2, 0), (17636, 346496, 1,
    0), (2166, 346496, 1, 0), (922, 346496, 1, 0), (5, 346496, 1, 0)!
    , (1341, 346496, 1, 0), (265, 346496, 1, 0), (280, 346496, 1, 0),
    (30203, 346496, 1, 0), (96, 346496, 1, 0), (1896, 346496, 1, 0), (2223,
    346496, 1, 0), (15, 346496, 1, 0), (966, 346496, 1, 0), (52, 346496, 1, 0),
    (7695, 346496, 1, 0), (33020, 346496, 1, 0)

    mysql error: Duplicate entry '115-346496' for key 1

    mysql error number: 1062

    Date: Saturday 03rd of April 2004 07:41:01 PM
    John
    diet support at diettalk.com

  • #2
    Try starting the search index again. The worst case is that you'll need to clear it and start from scratch.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I just went on to the next number... if I have any troubles, I'll just have to redo it again. How about similar threads, should we "index" from the start?

      fyi... I was also getting some users having this issue:

      Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in /var/www/html/forums/includes/db_mysql.php on line 281

      Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in Unknown on line 0
      I looked and increased the memory size from 16M to 32M .. I'm waiting to see if the issue continues.
      Last edited by diettalk; Mon 5 Apr '04, 9:51am.
      John
      diet support at diettalk.com

      Comment


      • #4
        After upping my memory size to 32M ... I just had someone post getting the same error? Do I need to up it to 64M?

        Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in /var/www/html/forums/includes/db_mysql.php on line 281

        Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in Unknown on line 0
        John
        diet support at diettalk.com

        Comment


        • #5
          After you uped the memory limit did you reload apache?

          Comment


          • #6
            yes, the server was actually rebooted yesterday.
            John
            diet support at diettalk.com

            Comment


            • #7
              Just wanted to make sure.

              Comment


              • #8
                How do you change the memory limit?

                Originally posted by Zachery
                After you uped the memory limit did you reload apache?

                Comment


                • #9
                  You need root access to the server, and you need to be able to edit php.ini

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X