Announcement

Collapse
No announcement yet.

sending email

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sending email

    vBulletin isnt sending its email. I tried sending email through vBulletin. It doesnt generate any errors. I do have the SMTP setting set up in my php.ini file.

  • #2
    When you tested php email, did you receive an email?
    Try going to admin control panel > vb options > vb options and then the "use -f parameter" to yes, and try again?

    Comment


    • #3
      Originally posted by Floris
      When you tested php email, did you receive an email?
      Try going to admin control panel > vb options > vb options and then the "use -f parameter" to yes, and try again?
      Tried that. Didnt make a difference.

      Comment


      • #4
        Originally posted by sbeard
        Tried that. Didnt make a difference.
        We also just upgraded to PHP 4.3.5. Also it is a Windows NT server.

        Comment


        • #5
          Originally posted by sbeard
          We also just upgraded to PHP 4.3.5. Also it is a Windows NT server.
          On another note....the email function worked fine before I upgraded to PHP 4.3.5.

          Comment


          • #6
            Sounds like a settings problem in php.ini. In the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I cant give you the URL because our forums are on an internal WAN. But Im attaching the php.ini file as an attachment.
              Attached Files

              Comment


              • #8
                I still wonder if it has anything to do with the fact that I upgraded to PHP 4.3.5. Email worked untill I upgraded. I even went back. Deleted the php folder and started from scratch and still have the same problem. My other test instance has the same problem. It is using PHP 4.3.5 also. The reason I wonder about this is because we have other php scripts that is not related to vB3 and its email finctionality broke also. What version of PHP is this forum using. Perhaps I should use the same if email is working fine for this. I have no problem downgrading if that is what it will take to get it working.
                Last edited by sbeard; Fri 2 Apr '04, 5:59am.

                Comment


                • #9
                  You need valid SMTP and sendmail_form settings:

                  [mail function]
                  ; For Win32 only.
                  SMTP = 32.86.178.140
                  ; For Win32 only.
                  ;sendmail_from = [email protected]

                  Enter a valid email address for sendmail_from. If you still have problem, try 'localhost' for the SMTP server.

                  If the SMTP server is on a different machine, then that machine will need to be cionfigured to accept STMP requests from your machine.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    It worked my dev server. Im going to apply to test and hope I get the same result.

                    Comment


                    • #11
                      Windows servers require this:

                      ; For Win32 only.
                      ;sendmail_from =
                      [email protected]

                      Your php.ini shows you don't have this set.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X