Announcement

Collapse
No announcement yet.

SuperAdministrator Cannot Change Permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SuperAdministrator Cannot Change Permissions

    I obviously have something screwed up in my install.

    SuperAdmins (me) are refused permission when trying to change Admin Group Privileges in the CP. however, the config.php file shows
    $superadministrators = '2'; "2" is my User Id.

    Additionally, I cannot make changes to SuperAdmin profiles. I get the "undeletable user" error message. However, config.php shows:
    $undeletableusers = '';

    Any help would be appreciated.
    Rich

  • #2
    That should work. Are you sure you are logged in under that account? Did you change config.php (as opposed to config.php.new)?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve-
      I know how it sounds and believe me, I'm gonna hate it when I find it was something stupid like that. But I've triple checked.
      I'm certain of the it's config.php and that I'm logged in and that my id is 2. All permissions are set to 755 on the php scripts.

      The very fact that <any> user could result in a "not deletable...change the config.php" when that variable is empty points to your question. Either we're reading config.php or we're reading something else. But i've not installed any script hacks.
      Rich

      Comment


      • #4
        If you have not installed any hacks, fill out a support ticket at:

        http://www.vbulletin.com/members/mem...ontactform.php

        Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. If you have installed hacks, then remove the hacks first then check and see if you still have this problem. If so, leave the default vB files in place and fill out the support request.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Steve-
          Before we go thru that, I think i've located the problem, though not the source. The server or the software appears to be serving up php pages from cache, rather than reading the scripts each time. Is this a VB feature? If so, how can I force it to rewrite the cache when I can't get into the CP?
          Thanks-
          Rich

          Comment


          • #6
            There is this option in the Admin CP vBulletin Options:

            Add No-Cache HTTP Headers
            Selecting yes will cause vBulletin to add no-cache HTTP headers. These are very effective, so adding them may cause server load to increase due to an increase in page requests.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Steve-
              Was already turned on. However, the good news is: problem solved. My WebMaster admits that he'd added a php caching routine last weekend that's been killing me ever since.
              Rich

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X