Announcement

Collapse
No announcement yet.

calendar db error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • calendar db error

    The following error pops up when trying to use the calendar:

    Database error in vBulletin 3.0.0:

    Invalid SQL:
    SELECT calendarpermission.usergroupid, calendarpermission.calendarpermissions,calendar.calendarid,calendar.title, displayorder
    FROM calendar AS calendar
    LEFT JOIN calendarpermission AS calendarpermission ON (calendarpermission.calendarid=calendar.calendarid AND usergroupid IN(13, 14, , 11))
    ORDER BY displayorder ASC

    mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 11))
    ORDER BY displayorder ASC' at line 3

    mysql error number: 1064


    Running vB3.0.0 Any idea why?

  • #2
    Reupload your calendar.php file in ASCII mode and repair and optimize your tables

    AdminCP > Import & Maitence > Repair / Optmize Tables, select all and hit continue

    Comment


    • #3
      Thanks, we'll give that a try.

      Comment


      • #4
        I am now getting this error message:

        Database error in vBulletin 3.0.0:

        Invalid SQL:
        SELECT calendarpermission.usergroupid, calendarpermission.calendarpermissions,calendar.calendarid,calendar.title, displayorder
        FROM calendar AS calendar
        LEFT JOIN calendarpermission AS calendarpermission ON (calendarpermission.calendarid=calendar.calendarid AND usergroupid IN(12, , 11))
        ORDER BY displayorder ASC

        mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 11))
        ORDER BY displayorder ASC' at line 3

        mysql error number: 1064

        Date: Thursday 01st of April 2004 12:09:58 AM
        Script: http://www.hobbytalk.com/bbs1/online.php?
        Referer:
        Username: eviltone
        IP Address: XX.XX.XX.XX

        Comment


        • #5
          I just found out that error happens when they try to view whos on-line. Seems to work for me but registered user throw out that error message. I reuploaded online.php and that didn't help.

          Comment


          • #6
            Run 'Find Updated Templates' and revert all the templates it finds. Then run 'Suspect File Version' in Diagnostics and report back the results.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Find Updated Templates = All Templates are up to date

              No suspect files found in any directory

              As a note I was getting this error before I upgraded from beta 4 to 3.0 I didn't bother with it because I knew I was going to upgrade fairly soon. This upgrade was actually done in a new directory and then the directory was renamed after the upgrade was complete.

              Comment


              • #8
                If you have not installed any hacks, fill out a support ticket at:

                http://www.vbulletin.com/members/mem...ontactform.php

                Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. If you have installed hacks, then remove the hacks first then check and see if you still have this problem. If so, leave the default vB files in place and fill out the support request.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  With some help from the member that was having the problem (he gave me his password so I could log in as him and see what his seetings were) I figured out what the problem was. I wanted to be able to confirm the problem before I submit a trouble ticket.

                  Somehow he had one of my secondary member groups in his primary member group list. Once I deleted that in my AdminCP the error message went away. I am not really sure how it got that way but is what was causing the problem.

                  Comment


                  • #10
                    I'm having this exact problem. can someone explain the above post to me please.

                    Comment


                    • #11
                      nevermind, I fixed it.

                      Comment


                      • #12
                        I've the same problem, how can i fix it?

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X