Announcement

Collapse
No announcement yet.

Server load shoots up on sundays!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server load shoots up on sundays!!

    Greetings,

    I've been having this problem since last month. The server load averages increase upto 40/30 every sunday afternoon. Therefore, accessing the site to the site is nearly impossible. I have to stop apache for a couple of minutes so the server loads can go back to their original state (below 1).

    I did a top on my server and found that the mysql process is what is causing this but I havent been able to figure out why. Any help or advice would be much appreciated.

    Regards,
    M1th
    Attached Files
    Chamber of Secrets - The Ultimate Harry Potter Community!

  • #2
    We could use some help with the standard info that Eva requests for server tuning.

    But on sundays you might want to turn any of the special features off, like checking that someone is subscriped. users browsing forums / threads. for example, if there already not.

    Comment


    • #3
      Originally posted by Zachery
      We could use some help with the standard info that Eva requests for server tuning.

      But on sundays you might want to turn any of the special features off, like checking that someone is subscriped. users browsing forums / threads. for example, if there already not.

      http://www.vbulletin.com/forum/showthread.php?t=91317

      As for turning off the feature, I'd like to know what is causing the problem first.
      Chamber of Secrets - The Ultimate Harry Potter Community!

      Comment


      • #4
        You have a ton of sleeping processes, not sure if thats good or bad, but are you using usepconnect?

        Comment


        • #5
          Originally posted by Zachery
          You have a ton of sleeping processes, not sure if thats good or bad, but are you using usepconnect?

          Nope, its off.
          Chamber of Secrets - The Ultimate Harry Potter Community!

          Comment


          • #6
            Okay, this is annoying. It's doing it again!

            45.18, 29.01, 12.36 !!!
            Chamber of Secrets - The Ultimate Harry Potter Community!

            Comment


            • #7
              Check your root cronjobs to see what may be running on Sundays.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                You sure this happens only on sunday?
                You run apache 2 right ?

                Could you run the server with apache 1 and see if it makes a difference ?

                Comment


                • #9
                  You sure this happens only on sunday?

                  Good point.. im not really sure.


                  And to add to this problem, everytime I try to update a template in admincp, the server screws up again (high mysql process)


                  Steve, "no crontab for root"
                  Chamber of Secrets - The Ultimate Harry Potter Community!

                  Comment


                  • #10
                    Do you have any other users with root privileges? I would suspect a cron job if this happens at the same time on a regular basis.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol
                      Do you have any other users with root privileges? I would suspect a cron job if this happens at the same time on a regular basis.

                      Nope, not that I know of.
                      Chamber of Secrets - The Ultimate Harry Potter Community!

                      Comment


                      • #12
                        Does your host have a regularly schedule backup script running?
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          I have a problem which might be related. Everytime I do a mysqldump, the MySQL server will have very high load after that (can be as high as 5.00 when busy and perhaps .5 when not busy). The only way I could bring it back to normal is to restart the MySQL server. I never had this problem before until recenly when I upgraded the hardware as well as now the MySQL is at version 4.018. The new hardware is more powerful than the old server. It is a dual Athlon MP with 2GB of RAM. I suspect it might be something to do with innodb, unfortunately I need innodb for another database.

                          I am doing the back up dump now at the replicate Slave server, which has not given me any problem. The back up script stops Slave before the dump and starts the slave afterwards. First I thought it might be my my.cnf's memory related settings. I have since tried many different settings. I will have to study more into MySQL before trying other settings, it is a live server.

                          Comment


                          • #14
                            Originally posted by Steve Machol
                            Does your host have a regularly schedule backup script running?

                            Nope, we do the backups ourselves.
                            Chamber of Secrets - The Ultimate Harry Potter Community!

                            Comment


                            • #15
                              er.. *bump* :|
                              Chamber of Secrets - The Ultimate Harry Potter Community!

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X