I'm currently using version 4, the latest. But I would like to upgrade to 5 (also the latest) as I have it. But the upgrading process is slightly confusing to me. Is there anyone who could break the process...