Announcement

Collapse
No announcement yet.

Email Notification does not work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Notification does not work.

    This is my third try at this, I cannot get email notification to work.
    even the confirmation email for new sign ups doesnt work.

    The email from admin control for the email test works perfectly.

    but nothing else does.

    There are NO entries in ANY mail logs for any attempts even, I can find the test email from the admin controls, but none of the thread notifications, or send email to others works.

    I'm willing to try about anything at this point besides reinstalling everything.
    I have RC4

  • #2
    If there are no entries at all in the mail logs then I would have no idea at all how to troubleshoot this. Hoenstly it doesn't make any sense to me.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      no entries in the logs besides the email I send from the admin panel.

      maybe its something stupid, like a php file for the board that got deleted or corup or something??

      I can get a copy of hte logs if you wish.

      Comment


      • #4
        where do put in the path to the mail prgram again?

        I wanna double check, but cant seem to find it now.

        Comment


        • #5
          It should be set in php.ini.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            MAIL /var/mail/life

            I found that in the php.ini under environment.

            doesnt seem right to me???


            but when I do the test email after I send it I get this

            SMTP:localhostsendmail_from:Nonesendmail_path:/usr/sbin/sendmail -t -i


            does that all look the way it should, the sendmail path is correct there.
            and I do get the test email very fast.

            Comment


            • #7
              That all depends on how your server is configured. Is this a dedicated server or are you on a shared server?

              Also in the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol
                That all depends on how your server is configured. Is this a dedicated server or are you on a shared server?

                Also in the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
                www.fastcompany.ca/forum

                its a shared account on www.sitevalley.com severs.
                They are being as helpful as they can while still having no idea whats going on.

                Comment


                • #9
                  From that I can determine than as long as they have sendmail running from this location: /usr/sbin/sendmail -t -i

                  ...and it's on the local server, then email should work. What does your host say about this?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    I'm working on it with my host, neither one of us can figure out a reason why it wont work... but yet the test will.... jsut doesnt make sence.

                    Comment


                    • #11
                      Question
                      In a bid to fix this and move the forum to forum.fastcompany.ca

                      Can I:
                      install this VB3 Gold into forum.fa...ny.ca and then just take the config.php from www.fastcompany.ca/forum (where the forum currently is, and its rc4)

                      Can I do that and have everything come out looking the same as it was?
                      Does that have the slightest possibility of fixing the notification?

                      Comment


                      • #12
                        OK I installed the new one, then used my old database, and the email still doesnt work.
                        when I was using a new database the email notification worked, but as soon as I made it the new database it stopped working.

                        So to me that says something in the database is causeing it..... I dont know what that means, but I hope it narrows it down to soemthing.

                        Comment


                        • #13
                          I don't understand the comments about the databases. Can you explain?
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            umm ok
                            I installed vb RC3gold into a new dir, gave it a brand spankin new myspl database, so I was the only member... i then made a new member, test1, i used that memeber and my admin loging to reply to a thread, I would get the email notifications of the replies every time.

                            So at that point I took the config.php from my live forum and placed it into my new test forums, so now I had two instances of the same forum, one running gold, and one rc4. both off hte same database.
                            I didnt know if this would cause a problem, so I turned my live board of for a few minutes.

                            now on my test forum with my live forums database I got a couple mods and myself to reply to a thread that we all subscribed to. but none of us got an automated responce.
                            The test email from the admin control still sent one.

                            So its not the scripts, its something that is saved in the database that is cuase my no email problem.

                            Comment


                            • #15
                              Originally posted by Xride
                              So at that point I took the config.php from my live forum and placed it into my new test forums, so now I had two instances of the same forum, one running gold, and one rc4. both off hte same database.
                              I didnt know if this would cause a problem, so I turned my live board of for a few minutes.
                              Yes, this is definitely a problem. You can't do this.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X