Announcement

Collapse
No announcement yet.

Not authorized to execute SQL queries

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not authorized to execute SQL queries

    When clicking on Execute SQL Queries under Import and Maintainance in ACP, I get a message saying I'm not authorized to do so. If not me, then who? How might I go about changing this? All admin permissions are set to "Yes".
    Chop Dewey

  • #2
    Originally posted by Contramontanum
    When clicking on Execute SQL Queries under Import and Maintainance in ACP, I get a message saying I'm not authorized to do so. If not me, then who? How might I go about changing this? All admin permissions are set to "Yes".
    It's in /includes/config.php

    Comment


    • #3
      Works now. Thanks!
      Chop Dewey

      Comment


      • #4
        This answered my question too, thank you!
        http://www.communitygala.com

        Comment


        • #5
          Mine too. Thanks for the help.
          Project4Hire.com - Find Freelance Progammers and Graphic Designers for all your project needs
          Webmaster forum

          Comment


          • #6
            And me, couldn't find it anywhere in the options.
            Cheers

            Comment


            • #7
              Helped me too!

              Comment


              • #8
                Originally posted by assassingod View Post
                It's in /includes/config.php
                What is in there that needs to be done to be able to execute sql queries? Does something in that file need to be added or changed?

                Comment


                • #9
                  To run queries you first need to give yourself permission to run queries in the Admin CP. To do this, edit this section of config.php:

                  $config['SpecialUsers']['canrunqueries'] = 'x';

                  ...with x being your userid number.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Not working for me...

                    This was an easy fix, yet even though I inserted my user name at the 'x':

                    $config['SpecialUsers']['canrunqueries'] = 'x';

                    Saved and over wrote the file on the server, it still replies with:

                    You are not authorized to execute SQL queries

                    Closed browser, relogged in, same thing. Check the file, overwrite again. Try over, same thing. I cannot get it to work? I am using version: 3.8.4

                    My user name is two upper case letters followed by my last name like this: "X X Xxx" Is the system picky about a two spaces in the user name? Don't know what else to try.

                    Comment


                    • #11
                      UserID.

                      Comment


                      • #12
                        Okay, I changed my User ID to XXXxx with no spaces, restarted the browser, and tried in IE and Firefox and it still reports:

                        You are not authorized to execute SQL queries

                        Anyone have an answer without wasting time pitching horseshoes?

                        Comment


                        • #13
                          You need to use your user ID number (NOT YOUR USERNAME), which is the number at the end of the URL when you hover over your username in a post. On this forum, your userid is 233235. On your forum it will be different.

                          My userid on my forum is 12, therefore my line in the config file reads:

                          $config['SpecialUsers']['canrunqueries'] = '12';

                          Not throwing horseshoes. I'm correct, you're just doing it wrong, or not following instruction.

                          Comment


                          • #14
                            Thanks, finally a detailed response.

                            I suppose if a person worked with their vBulletin at an installation level on occasion, such information would be a given, but some people have other prerogatives. It was the final explanation that revealed the missing details.

                            I know other people will scour for this obscure information in the future, therefore I will mention that “hovering” over the name does not produce any results. However, if you access Admin Control Panel, and search for your own user name under the USERS panel on the left, the User ID is displayed by your User Name as (id: x) top left.

                            Notice, no vague acronyms or “mind-readers try to guess” feedback, just clear defined directions

                            Comment


                            • #15
                              If your comprehension skills were up to scratch, you'd have been sorted a while ago. Steve's first post:
                              ...with x being your userid number.

                              Pretty sure your username isn't a number.

                              Meh, either way. You're welcome...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X