Announcement

Collapse
No announcement yet.

I can't get custom avatars to work!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I can't get custom avatars to work!

    I know we're running PHP in safe mode, so I checked the option and put in the loooong path to a directory I created for them (/usr/local....yadda/images/attach/avatars) and CMODed it 777. I set a limit of ~100k for uploads. I set a dimension size of 125. Now, when I go to upload any file, I get "The uploaded file is not a valid GIF or JPG file. Please ensure that it is an try again." It's within the size and filesize specs, so what's the problem? Any clues?
    [edit]this is on 2.0 beta2[/edit]

  • #2
    me either...

    I don't know if I'm having the same problem or not, but I can't get Avatars to work at all. I've tried adding them manually through the control panel (using a couple I grabbed from here). Typed in the complete path, even uploaded them via FTP to make sure they are there. All that shows up via the avatars section in the control panel are the imfamous red Xs.

    Any idea what I'm doing wrong?

    Comment


    • #3
      It may be that your path is off. The upload option (to grab all avatars in a specific folder) says you need to type the path to the folder relative to your forum folder. In my case, it was images/avatars --note, no beginning or ending slash.

      HTH,

      Comment


      • #4
        Well, that worked under the control panel (they now show up in the control panel), but didn't work for the BBS. All the images still show up as an X under the user name. I went in the profile and deleted the avatar and re-added, and it's still showing up as an X. Any other thoughts?

        Comment


        • #5
          When I had that problem, I had added a / before the "images" ie I put /images/avatars when I should have put images/avatars . If that's not the problem, right click and choose properties on the image and see if the URL is mangled somehow and adjust your path accordingly.

          HTH,

          Comment


          • #6
            Ummm, so does anybody have any ideas for *me*???

            Comment


            • #7
              here how u do it

              Well lets see... Fist you should do this..
              Say you got a folder of avatars called Avatars. FTP it into your forums folder.. sumthin like this
              www.yourhost.com/forums/Avatars
              Then you go to add avatars. When it asks you for the image path type this in..
              Avatars/Abu.gif or any image that is in the folder. And there you have it ..

              Comment


              • #8
                Re: here how u do it

                Originally posted by xRated
                Well lets see... Fist you should do this..
                Say you got a folder of avatars called Avatars. FTP it into your forums folder.. sumthin like this
                www.yourhost.com/forums/Avatars
                Then you go to add avatars. When it asks you for the image path type this in..
                Avatars/Abu.gif or any image that is in the folder. And there you have it ..
                that's what i did and have 660 custom avatars added
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  I think we're not on the same page here. I have the regular avatars working. It's the custom avatars (ie: uploaded by the user) that won't work. If a user goes to upload one, it either gives the error in the first message or acts like it did it and does nothing. Hmmm now I'm thinking about it and if it's "relative to the forums folder" like the other one, I may have fouled up again on the same mistake. LOL....brb to tell you if it worked.

                  [edit]Okay, no...it still doesn't work. I've caused the confusion here (what's new? LOL). It's all about the file uploads, because attachments aren't working either. It's the option at the very end of the options page. The one about allowing uploads if you're on a server running php in safe mode... no matter how I type that path, it still won't allow a user to upload an avatar. Anybody using PHP in safe mode that got the file attachements/custom avatars to work?
                  Last edited by Susan; Sat 24 Feb '01, 4:37am.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X