Announcement

Collapse
No announcement yet.

Errors: Table Headers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors: Table Headers

    I am getting the following errors after moving my forum to a new server. The forums are there but under the following:

    "Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 224

    Warning: fopen("/proc/loadavg", "r") - Operation not permitted in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 224

    Warning: fclose(): supplied argument is not a valid File-Handle resource in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 226

    Warning: Cannot add header information - headers already sent by (output started at /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php:224) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/functions.php on line 1712"

    Is there anybody who knows where to point me or a f.a.q. that handles this?

    T.I.A.

  • #2
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
      Hi Steve,

      I uploaded the phpinfo.php to the site. http://birdsandmoons.com/board/

      Let me know if you can't get to it. There seems to be some DNS resolution issues with the site right now. If needed, I can send you the physical IP and you can add it to your host file.

      Comment


      • #4
        Originally posted by Phil Macino
        Hi Steve,

        I uploaded the phpinfo.php to the site. http://birdsandmoons.com/board/

        Let me know if you can't get to it. There seems to be some DNS resolution issues with the site right now. If needed, I can send you the physical IP and you can add it to your host file.
        Symptom update:

        It looks like users are unable to log in as they are continually prompted for there user name and password. Once the finally get to screen to reply to a post, they get prompted once again than booted.

        I tried logging in with my admin account though the forums main page and received the same result. However, by logging in via the admin console, then clicking the link in the upper right of the admin cp....it works...with the same messages showing as in my first post on this issue.

        Comment


        • #5
          First of all, I strongly recommend that you upgrade to PHP 4.3.4. The version you are running (4.2.2) has a number of serious problems.

          Second, you have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

          /home/httpd/vhosts/birdsandmoons.com/httpdocs/tmp

          Hopefully this will be enough. However since you are on a 'vhosts' server you may also need to followthe instructions in this thread:

          http://www.vbulletin.com/forum/showt...threadid=37766
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol
            First of all, I strongly recommend that you upgrade to PHP 4.3.4. The version you are running (4.2.2) has a number of serious problems.

            Second, you have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

            /home/httpd/vhosts/birdsandmoons.com/httpdocs/tmp

            Hopefully this will be enough. However since you are on a 'vhosts' server you may also need to followthe instructions in this thread:

            http://www.vbulletin.com/forum/showt...threadid=37766
            Thanks Steve. Will do, and post a follow up.

            Comment


            • #7
              I did the suggestions and now get this...

              Warning: open_basedir restriction in effect. File is in wrong directory in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 224

              Warning: fopen("/proc/loadavg", "r") - Operation not permitted in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 224

              Warning: fclose(): supplied argument is not a valid File-Handle resource in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php on line 226

              Warning: Cannot add header information - headers already sent by (output started at /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php:224) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/functions.php on line 1712

              Warning: Cannot add header information - headers already sent by (output started at /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php:224) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/functions.php on line 1712

              Warning: Cannot add header information - headers already sent by (output started at /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php:224) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/functions.php on line 1712

              Warning: Cannot add header information - headers already sent by (output started at /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/global.php:224) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/functions.php on line 1712

              Comment


              • #8
                Something was not done correctly because you are still getting the open_basedir error. Either that or you will need to follow the extra instructions in the link I posted:

                http://www.vbulletin.com/forum/showt...threadid=37766
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol
                  Something was not done correctly because you are still getting the open_basedir error. Either that or you will need to follow the extra instructions in the link I posted:

                  http://www.vbulletin.com/forum/show...&threadid=37766
                  I did do the extra step in the link...I followed the directions for a dedicated server. Should I try it again?

                  Comment


                  • #10
                    As far as I know either my instructions ot those instructions should have worked. I suggest double-checking everything.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I did check everthing twice and everything is as you suggested. I tried doing a second parallel installation with a database I created in Plesk on the same domain and this was the result...even though I verified all of the info in the config.php prior to install

                      Attempting to attach to database...


                      Warning: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 40

                      Warning: MySQL Connection Failed: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 40

                      Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 47

                      The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.



                      Click

                      Comment


                      • #12
                        Originally posted by Phil Macino
                        I did check everthing twice and everything is as you suggested. I tried doing a second parallel installation with a database I created in Plesk on the same domain and this was the result...even though I verified all of the info in the config.php prior to install

                        Attempting to attach to database...


                        Warning: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 40

                        Warning: MySQL Connection Failed: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 40

                        Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/httpd/vhosts/birdsandmoons.com/httpdocs/BAM/admin/db_mysql.php on line 47

                        The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.



                        Click
                        I should also add that I did use SSH to access the db through root and entered the db after using the same credentials that I am not allowed to connect with through the vB install

                        My original dB was moved over from a shared server and "just worked" (with the errors in the first post) after uploaded the forum files via ASCII to the mirrored directories on the dedicated server even though the IP address was never changed from the original install.

                        After I changed the original IP address in the config.php to reflect the new server "birdsandmoons.com" (since I am using Plesk now) and I now receive this...

                        Warning: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/db_mysql.php on line 40

                        Warning: MySQL Connection Failed: Host '216-55-163-42.dedicated.abac.net' is not allowed to connect to this MySQL server in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/db_mysql.php on line 40
                        P,BODY{FONT-FAMILY:tahoma,arial,sans-serif;FONT-SIZE:11px;}


                        There seems to have been a slight problem with the database.
                        Please try again by pressing the refresh button in your browser.

                        An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

                        We apologise for any inconvenience.


                        I am beginning to wonder if there wasn't something I missed in the transer or some other Plesk vB issue that I failed to see.

                        Comment


                        • #13
                          Try setting the servername back to 'localhost'.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by Steve Machol
                            Try setting the servername back to 'localhost'.
                            in the config.php?

                            Comment


                            • #15
                              Originally posted by Phil Macino
                              in the config.php?
                              This is the result:


                              <B>
                              Warning: Access denied for user: '[email protected]' (Using password: YES) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/db_mysql.php on line 40

                              Warning: MySQL Connection Failed: Access denied for user: '[email protected]' (Using password: YES) in /home/httpd/vhosts/birdsandmoons.com/httpdocs/board/admin/db_mysql.php on line 40
                              P,BODY{FONT-FAMILY:tahoma,arial,sans-serif;FONT-SIZE:11px;}


                              There seems to have been a slight problem with the database.
                              Please try again by pressing the refresh button in your browser.

                              An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

                              We apologise for any inconvenience.

                              </B>

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X