Announcement

Collapse
No announcement yet.

Attachment upload problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment upload problem

    I can upload large attachments from a browser on my server.
    I can upload small attachments from a browser on my client (under a meg)
    I can NOT upload large attachments from a browser on my client (4 meg)

    Fatal error: Maximum execution time of 30 seconds exceeded in D:\vbulletin2\<snip>\upload\newthread.php on line 2

    I increased the post time to 18000 seconds (5 hours)
    I increased the PHP max upload size from 2 meg to 50 meg
    I increased the mysql max_allowed_packet from 1 meg to 16 meg

    What I see is that the IE gas gauge on the status bar slowly fills. Once it gets to 100% it fails with the misleading timeout of 18000 seconds... which really happened in just over a minute.

    Support told me to upgrade to 3.0.0 RC4 to see if that fixed it... it did not. Then they told me that they do not support v3 at to register with the forum. They then told me to go back to 2.3.4. which I am back at and did all of the test above with, which still does not work. Support is thinking about it.

    Ideas?

    Sincererly,
    The New (highly annoyed) vBulletin administrator

  • #2
    To avoid piracy, you might want to remove the license number from your post.

    Comment


    • #3
      You could change the maximum execution time in php.ini from 30 seconds to something larger.

      Comment


      • #4
        In addition you might want to look at the sticky at the top of the Server Configuration thread. It sounds like the server needs tuning.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Freddie Bingham
          You could change the maximum execution time in php.ini from 30 seconds to something larger.
          I up'ed it to 18000 seconds and it still failed, lasted longer, but still failed. I'll look at the Configuration sticky and see what's in there.

          Comment


          • #6
            what is the PHP Maximum Upload Size and MySQL Maximum Packet Size
            If their too small vB probally will not be able to upload large files.

            Also in the attachments section, do you allow such lage file sizes to be attached.

            Comment


            • #7
              I looked at the thread(s) and didn't see anything that jumped out at me. Support told me that there isn't anything they can do (LOL) and recommended I go *find* the answer here. Such a nice Welcome aboard to a new customer


              php.ini settings...
              upload_max_filesize = 50M
              max_execution_time = 18000

              Categories/threads set to allow 50 meg attachments

              c:\my.cnf
              [client]
              set-variable = max_allowed_packet=16M

              [mysqld]
              set-variable = max_allowed_packet=16M

              Everything else is set based on medium mysql sample configuration file.

              Comment


              • #8
                Is your mysql server on the same machine as your webserver? What is your connection speed to the internet? How long would it take you to upload a 4 meg file to your mysql server using a ftp client?

                Comment


                • #9
                  Windows 2000 Server SP4
                  P4 2.4 gig
                  2 gig physical RAM

                  Installed on this one and only server...
                  php 3.0
                  mysql 4.0.17
                  vbulletin 2.3.4

                  ftp not installed (yet)
                  "copy" over mapped drive from my machine over 1.5m connection to server: 2.9 meg file, 1 minute 20 seconds.

                  Remember that if I do a 3 meg file or a 6 meg file, it shows the status bar slowly filling until it gets to 100%. Once @ 100%, it sits there for 5 - 10 seconds more then gives me the 18000 timeout. I think there is some other error going on and this is just the only thing that the page could guess the problem is.

                  Comment


                  • #10
                    I just used vbulletin to upload a 1.3 file over the remote connection and it took 10 seconds. So all in all it works, but bigger sizes do not.

                    Comment


                    • #11
                      Originally posted by Tobin
                      Support told me that there isn't anything they can do (LOL) and recommended I go *find* the answer here. Such a nice Welcome aboard to a new customer
                      Actually Martin stated that this is a server issue - which it is - and consequently we do not have much control over this. It's possible that the server needs to be optimized. For help with optimizing your server, please see this thread:

                      http://www.vbulletin.com/forum/showt...threadid=70117

                      Then post the requested info in a new thread in that forum.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        i sympothise with you i jus got the vbullitin software and i look all over this board and see this issue time and time again if its a server issue then every server vbullitin is loaded on is bad then [singned] very very disapointed

                        Comment


                        • #13
                          I can on my own boards upload attachments up to 16mb with out any issues, sorry you have a problem with your host.

                          Comment


                          • #14
                            There are several webserver, mysql, and PHP settings that directly control the amount of data that is allowed to be posted back to the website. You must change these settings to allow larger files to be uploaded. Savings attachments in the filesystem will bypass the mysql limits but not the webserver or PHP settings.

                            Comment


                            • #15
                              webwizard2, this thread is over a year old. Please start a new thread with your exact situation so we can help.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X