Announcement

Collapse
No announcement yet.

SQL problem trying to split thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL problem trying to split thread

    Oven-fresh install of 2.2.8 on a NT4 box with the recommended PHP/SQL goodies. When I try to split a thread by radio-buttoning the desired posts and kicking it off, I get this. About the only non-stock thing I've done so far is change the date format to my preference (seen in the error message). Any help will be cherished. Thanks.


    Database error in vBulletin 2.2.8:
    Invalid SQL: INSERT INTO thread (threadid,title,lastpost,forumid,open,replycount,postusername,postuserid,lastposter,dateli ne,views,iconid,notes,visible) VALUES (NULL,'Janet Jackson\'s nipple.','1076218905','10','1','12','Matt','1','Matt','1076000830','51','0','Thread split from threadid 15 by Matt on 8 Feb '04 12:47am. ','1')
    mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '04 12:47am. ','1')' at line 1

    mysql error number: 1064

    Date: Sunday 08th of February 2004 12:47:27 AM
    Script: http://mattdrury.net/bbs/bbs/postings.php
    Referer: http://mattdrury.net/bbs/postings.php
    http://mattdrury.net/bbs (since 1984)

  • #2
    Your hard drive must have kept an old copy of the 2.2.8, vBulletin has past on to 2.3.4 and I advice you to upgrade to this version. Then you can be sure of proper files and full support.

    Comment


    • #3
      I believe this may have been a bug in older version of vB and newer versions of MySQL. You need to upgrade to the latest version.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Thanks. I'm on 2.3.4 now, simply enough, and that did the trick nicely. Thread splitting bliss.
        http://mattdrury.net/bbs (since 1984)

        Comment


        • #5
          Originally posted by floris
          Your hard drive must have kept an old copy of the 2.2.8, vBulletin has past on to 2.3.4 and I advice you to upgrade to this version. Then you can be sure of proper files and full support.
          Thanks, I did. The last time I upgraded the BBS was 2.2.8, and I've been away for a while. All better now.
          http://mattdrury.net/bbs (since 1984)

          Comment


          • #6
            Happy to hear things are resolved.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X