Announcement

Collapse
No announcement yet.

Sleeping Connections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sleeping Connections

    My vB is leaving sleeping connections to mySQL. This is causing issues for both my site and other sites using mySQL on the same server. My host reports that no other sites are doing this. How do I stop it?

  • #2
    You can try turning persistent connections off in your config.php:
    PHP Code:
    // ****** PERSISTENT CONNECTIONS ******
    // This option allows you to turn persistent connections to MySQL on or off.
    // The difference in performance is negligible for all but the largest boards.
    // If you are unsure what this should be, leave it off.
    // 0 = Off; 1 = On
    $usepconnect 0
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Are you using Persitant Connections?

      In your config.php there is a varible $userpconnect

      If this is set to 1 try changing it to 0 and see if it resolves the problem.

      Comment


      • #4
        It is off, I looked.
        Code:
        // use persistant connections to the database
        // 0 = don't use
        // 1 = use
        $usepconnect = 0;

        Comment


        • #5
          If this is off, then vB is not leaving any 'sleeping' MySQL connections.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            So does that mean it has nothing to do with vB even though my board's the only one that's doing it?

            Comment


            • #7
              It means I don't see how vB could be leaving any MySQL connections open.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X