Announcement

Collapse
No announcement yet.

Regarding .... "Link-ID == false"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Regarding .... "Link-ID == false"

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: User has already
    more than 'max_user_connections' active connections

    mysql error number: 1203

    Date: Friday 19th of December 2003 04:33:46 AM


    Is it possible that this error is caused by an overload of robots surfing our boards? I have made no changes at all to my board over the last 3 or 4 months and suddenly today I got this error. When I checked whos online there were approx 25 googlebots chewing on my threads.

    Could this be the cause of all of this? It's definitely not from any changes I made and I've never had this happen before. Board access appears to have returned now, but I'm curious as to the cause of this one. Thanks.
    :p -=Xube ®
    ...it's just technology

  • #2
    Originally posted by Xube


    Is it possible that this error is caused by an overload of robots surfing our boards?
    Yes.

    Try turning off persistant connections in your admin/config.php file. Open that file and set $usepconnect = 0. If that option is already off, then you can try asking your host to increase the max connection limit on MySQL.

    Comment


    • #3
      Optimal board function....

      Originally posted by Jakeman
      Yes.

      Try turning off persistant connections in your admin/config.php file. Open that file and set $usepconnect = 0. If that option is already off, then you can try asking your host to increase the max connection limit on MySQL.
      Ok, will try that. I am concerned at how it might affect my board users. What is the purpose of that file not being set at zero to begin with? Will setting it at zero possibly cause more board forced user log-offs (possibly while they are composing a post or whatever)?

      With an optimally functioning max connection MySQL limit from my host, what exactly is the purpose of that file's non-zero settings?
      :p -=Xube ®
      ...it's just technology

      Comment


      • #4
        PS: Since the sticky by Steve regarding this issue above is locked, there is no feedback from actual board users as to if this proposed fix is successful or how often it is successful.

        If anyone else had this problem, I would appreciate posting of feedback here on how or if this persistant connections file change was successful in resolving the issue (and whether it caused other user issues such as more frequent log-offs). Thanks all.
        :p -=Xube ®
        ...it's just technology

        Comment


        • #5
          To be honest I have never heard of any meaningful difference by turning persistant connections off. Since you can always turn it back on again you really don't have much to lose by trying it.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6


            Persistent database connections are just like leaving the front door open. It's easier to walk through the door because you don't have to open and close it each time, but you end up with a higher electricity bill (more RAM usage) because you are letting all of the heat out of the house. If you use too much electricity (exceed the max connection limit), then your mom yells at you to close the door (server gives you an error saying there are too many connections).

            But like Steve said, the benefit isn't really noticable.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X