Announcement

Collapse
No announcement yet.

problem after going from 2.3.1 to 2.3.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem after going from 2.3.1 to 2.3.3

    everything worked great and upgraded fine, but now when I go to try and log into my admin control panel I get this error

    Warning: main(./admin/config.php): failed to open stream: No such file or directory in D:\web\clubhonda.75\forums\admin\global.php on line 129

    please help, thanks!
    www.clubhonda.com

  • #2
    You have extra space or lines in your config.php file. Make sure there is no whitespace or extras lines in config.php either before the <?php or after the ?>.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thanks for the quick reply.

      there's no white space or lines before the <?php or after the ?> in the config.php file. there's white in between those two marks, but none before or after.
      www.clubhonda.com

      Comment


      • #4
        Well the problem is definitely in your config.php file. The default file only contain 40 lines and yours shows an error on line 129.

        I would save that file to a backup, copy the original config.php.new file to config.php, then edit config.php with the db variables. Providing you don't add any more lines and edit this correctly it should work.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I'll try what you said with the config.php file, but I thought that error message was referring to the global.php file which does have at least 129 or more lines.
          www.clubhonda.com

          Comment


          • #6
            Arrgg...you're right about the line number. However the problem is still with config.php. You might want to make sure it is world-readable.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hmmm...I believe the problem is that you are not using the global.php file for 2.3.3. Line 129 in the original file does not mention config.php at all.

              Reupload the original admin/global.php file from the 2.3.3 zip file. Make sure you upload in ASCII and overwrite the one on the server.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                hummmmmm, this is wierd, my 2.3.3 zip file contains three "global.php" files. one is 12k, the second is 8k, the third is 5.6k, which one do I use?
                www.clubhonda.com

                Comment


                • #9
                  well, after a little trial and error, the 8.6k file was the right one, then I had the wrong index.php file in the admin folder, so after that it was fine.

                  I'm not sure why it was messed up like that, I did the previous upgrade myself and that went flawless, wierd.
                  www.clubhonda.com

                  Comment


                  • #10
                    dang it, ok, now the control panel shows up, but what files am I missing that would make the...

                    "announcements add and modify" links not work?

                    "avatar add, modify, and upload" not work?

                    update counters page blank?

                    that looks like it, dammit, why did I upgrade, it was perfect before
                    www.clubhonda.com

                    Comment


                    • #11
                      Reupload ALL the 2.3.3 files (except for images and the 'extras' folder) and you won't have this problem. You need to make sure you are uploading in ASCII and overwriting the ones on the server.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        nice, that did it, I think I actually uploaded a mismatch of new and old files somehow, I'm a tard, looks to be very happy now, thanks!
                        www.clubhonda.com

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X