Announcement

Collapse
No announcement yet.

problems running vBulletin 2.3.3 using phpdev

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problems running vBulletin 2.3.3 using phpdev

    Dear All,

    I'm a happy new vBulletin customer. Here is my question: I have no experience working with PHP neither Apache nor MySql. So I decided to download the phpdev bundle from http://www.firepages.com.au/ to ease my life.
    -When I try to install vBulletin following the installations steps, I put this line in my url:
    http://localhost/admin/install.php. and I get the expected vBulletin welcome page.
    -Then I move to this page: http://localhost/admin/install.php?step=2 where I click on continue without updating values (since I don't seem to need to update them, at least for now) and that's when I click this button that my problem occurs:
    -I've got this adress in the url: http://localhost/admin/install.php?step=3 but unfortunatly I have an error notification:
    Attempting to attach to database...


    Warning: Failed opening './db_.php' for inclusion (include_path='.;C:/phpdev/php/includes;C:/phpdev/php/class') in c:\phpdev\www\admin\install.php on line 334

    Fatal error: Cannot instantiate non-existent class: db_sql_vb in c:\phpdev\www\admin\install.php on line 336


    could anyone tell me what is going wrong? Thanx a lot for help...
    Alex

  • #2
    In config.php you need to have $servertype set to 'mysql'.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      In config.php you need to have $servertype set to 'mysql'.
      it is.. here is the content of my config.php.new in the admin folder:
      Code:
      <?php
       
      /////////////////////////////////////////////////////////////
       
      // Please note that if you get any errors when connecting, //
       
      // that you will need to email your host as we cannot tell //
       
      // you what your specific values are supposed to be //
       
      /////////////////////////////////////////////////////////////
       
      // type of database running
       
      // (only mysql is supported at the moment)
       
      $dbservertype = 'mysql';
       
      // hostname or ip of server
       
      $servername = 'localhost';
       
      // username and password to log onto db server
       
      $dbusername = 'root';
       
      $dbpassword = '';
       
      // name of database
       
      $dbname = 'vbulletin';
       
      // technical email address - any error messages will be emailed here
       
      $technicalemail = '[email protected]';
       
      // use persistant connections to the database
       
      // 0 = don't use
       
      // 1 = use
       
      $usepconnect = 0;
       
      // which users are allowed to view the admin log
       
      // separate each userid with a comma
       
      $canviewadminlog = '1';
       
      // which users are allowed to prune the admin log
       
      // separate each userid with a comma
       
      $canpruneadminlog = '';
       
      ?>
       
      
      just unchanged...

      any more ideas?

      thank you very much for your answer

      regards
      Last edited by jeskel; Sat 13 Dec '03, 10:23am.
      Alex

      Comment


      • #4
        could the problem come from the fact that I'm using the phpdev bundle?
        Alex

        Comment


        • #5
          Have you set up a database with the db username password and db name in config.php?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol
            Have you set up a database with the db username password and db name in config.php?
            first I'm kind of confused between config.php and config.php.new... When you're talking about config.php are you actually talking about config.php.new?
            I have not set up anything in config.php.new. I've let it as shown in previous post. Should I config that?
            Alex

            Comment


            • #7
              ok here is how look my config.php file now:
              Code:
              <?php
              
              /////////////////////////////////////////////////////////////
              
              // Please note that if you get any errors when connecting, //
              
              // that you will need to email your host as we cannot tell //
              
              // you what your specific values are supposed to be //
              
              /////////////////////////////////////////////////////////////
              
              // type of database running
              
              // (only mysql is supported at the moment)
              
              $dbservertype='mysql';
              
              // hostname or ip of server
              
              $servername='localhost';
              
              // username and password to log onto db server
              
              $dbusername='alex';
              
              $dbpassword='testpassword';
              
              // name of database
              
              $dbname='testDB';
              
              // technical email address - any error messages will be emailed here
              
              $technicalemail='[email protected]';
              
              // use persistant connections to the database
              
              // 0 = don't use
              
              // 1 = use
              
              $usepconnect=1;
              
              ?>
              
              
              and here is the error message I get, on the same page as mentionned before:

              "Attempting to attach to database...


              Warning: Access denied for user: '[email protected]' (Using password: YES) in c:\phpdev\www\admin\db_mysql.php on line 38

              Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in c:\phpdev\www\admin\db_mysql.php on line 47

              The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly."

              what should these login details be? Am I not supposed to choose them myself?

              thanx a lot for your support! really appreciated!
              Alex

              Comment


              • #8
                This error means either:

                1. One or more of the following is wrong in your config.php file:

                $dbusername
                $dbpassword
                $dbname

                If you are unsure of what the appropriate values are then you will need to ask your web host.

                2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  At the moment I'm working on my local server to config and fine tune my vBulletin before putting it online. I'll go to a forum about mysql since it seems more appropriate now, however if you feel like keeping on helping me that would be a great pleasure. I'll keep on checking this thread.
                  1)how can that be wrong in my db file since I set it myself? compared to what is it wrong? How can I know what the values should be since I'm running on my com?
                  2) quote:"You may need to first manually create the database and assign the db user to it": how can do it?

                  thank you so much for your help!

                  sincerly yours,

                  Alex
                  Last edited by jeskel; Sun 14 Dec '03, 4:40am. Reason: words forgotten
                  Alex

                  Comment


                  • #10
                    1. I don't know why it's wrong - it just is. Otherwise you wouldn't get this error:

                    Access denied for user

                    2. This depends on your system. I use CPanel to create databases.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      ok... thank you Steve... I'll try to find what is going wrong... Maybe should I take some time to install MySql and Apache properly, not from the bundle.

                      Regards,

                      Alex
                      Alex

                      Comment


                      • #12
                        Just an idea, but you could try setting
                        $dbusername='root';
                        $dbpassword='';
                        in config.php

                        From my experience mySQL often ignores the user/password you set at the first start of the server, at least on Windows systems.

                        If that doesn't work, either check through the help files that came with the test server, or try setting up a "real" Apache/php/mySQL server. It really ain't that difficult and I'll send you a step-by-step if you want. Although I got the feeling that one is posted in the help files in the members' area, but I'm not sure.

                        Last edited by WannabeArtist; Mon 15 Dec '03, 7:19am.

                        Comment


                        • #13
                          ah man....................... thank you so much!!!!!!!!!!!!!!!! It works perfectly... Well, I definitly wanna thank you for it. I tried so many things that did not work.

                          btw, could you send me the step-by-step doc? that is gonna useful pretty soon!

                          thank you again WannabeArtist.

                          Regards,

                          Alex
                          Alex

                          Comment


                          • #14
                            OK, here goes a step-by-step guide tin installing an Apache/mySQL/PHP Test-server on a Windows System:

                            1) Installing mySQL (http://www.mysql.com/get/Downloads/M....zip/from/pick): Just download the package, unpack it and run the setup. It's a standard setup, so nothing that needs explaining. Once that is done, go to the install dir (for example c:\program files\mysql\) and run winmysqladmin.exe in the subdir \bin\ . It will ask you for a username and password, but usually it won't store those for some reason. We will set up access restrictions later on.

                            2) Installing PHP (http://at.php.net/get/php-4.3.4-Win32.zip/from/a/mirror): Get the zip file and unpack it to some place. Move all files from within the unpacked dir to c:\program files\php\ . Now copy php4ts.dll from c:\program files\php\ to c:\windows\system32\

                            3) Installing Apache2 (http://apache.netmonic.com/httpd/bin...x86-no_ssl.msi): Get the install package, run setup and fill out the needed info. For a local testserver just put localhost in all fields (and [email protected] in the last one). When choosing an install dir I'd suggest not using the default one, and instead install it to c:\program files\ without any subdir, as the seup will create an apache2 dir anyway.

                            4) Installing a mysql GUI (http://www.mysqlfront.de/download.html): I'd suggest going with version 3.0 as that one got mysql 4.0 support. This setup is really self-explaining.

                            5) Configuring:

                            5.1) Apache2: Open C:\Program Files\Apache2\conf\httpd.conf in a text editor. Around line 130 add the following:
                            LoadModule php4_module "c:/programme/php/sapi/php4apache2.dll"
                            AddType application/x-httpd-php .php
                            Around line 320 you should see "DirectoryIndex". Replace that line with
                            DirectoryIndex index.php index.htm index.html index.html.var
                            Restart Apache2 (you should have a green arrow in your taskbar that controls Apache2).

                            5.2) mysql-front/mysql: At first start the program usually crashes on me with an access violation. Just confirm the error notes and start the program again, it will work the second time without a problem. Now you just need to put the mysql server info, whoch would be server localhost, user root and no password. Now connect. Select mysql database, go to SQL Editor, paste and run the following:
                            Code:
                            UPDATE user SET `Select_priv` = 'N', `Insert_priv` = 'N', `Update_priv` = 'N', `Delete_priv` = 'N', `Create_priv` = 'N', `Drop_priv` = 'N', `Reload_priv` = 'N', `Shutdown_priv` = 'N', `Process_priv` = 'N', `File_priv` = 'N', `Grant_priv` = 'N', `References_priv` = 'N', `Index_priv` = 'N', `Alter_priv` = 'N', `Show_db_priv` = 'N', `Super_priv` = 'N', `Create_tmp_table_priv` = 'N', `Lock_tables_priv` = 'N', `Execute_priv` = 'N', `Repl_slave_priv` = 'N', `Repl_client_priv` = 'N' WHERE `Host` = '%' AND `User` = 'root'
                            You will need to reload access priviliges for this to take effect, but I couldn't find the option in MySQL-Front. Once completed, this will disallow access to your mysql server from outside.


                            OK, I think I included everything needed to get a WAMP (Windows, Apache, MySQL, PHP) server up and running. Feel free to add anything I might have forgotten.

                            Comment


                            • #15
                              thanks a lot.
                              Really helpful.

                              Reagards,

                              Alex
                              Alex

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X