Announcement

Collapse
No announcement yet.

Having problem with sending mail through vBulletin.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having problem with sending mail through vBulletin.

    I am having problems with sending out emails, both for activation emails and normal user emails.

    The email system works because I used the mailtest.php and it worked fine (I received the email, and no errors).

    But whenever a user registers or the board tries to email somebody for whatever reason, I get a a Mail Delivery System: Mail Delivery Failed message at my email.

    Here is a sample of what I get for the Failed Delivery Email when someone registers:


    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    [email protected]

    unrouteable mail domain "hotmail.com"

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <[email protected]>

    Received: from nobody by houston.dnschamber.com with local (Exim 4.24)

    id 1AIK8u-0001xG-Fj

    for [email protected]; Fri, 07 Nov 2003 21:52:08 -0600

    To: [email protected]

    Subject: Action Required to Activate Membership for Late Night Radio!

    From: "Late Night Radio Mailer" <[email protected]>

    Message-Id: <[email protected]>

    Date: Fri, 07 Nov 2003 21:52:08 -0600



    Dear TESTING,

    Thank you for registering for the Late Night Radio forums. Before we can activate your account one last step must be taken to complete your registration!

    Please note - you must complete this last step to become a registered member. You will only need to click on the link once, and your account will be updated.

    To complete your registration, click on the link below:

    http://www.latenightradio.org/forums/register.php?a=act&u=140&i=xxxxxxxx

    <a
    href=http://www.latenightradio.org/forums...140&i=xxxxxxxx>AOL Users click Here to be Activated</a>

    **** Does The Above Link Not Work? ****

    If the above link does not work, please use your Web browser to go to:
    http://www.latenightradio.org/forums/register.php?a=ver

    Please to be sure not to add extra spaces. You will need to type in your username and activation number on the page that appears when you click on our copy the above link in your browser.

    Your Username is: TESTING

    Your Activation ID is: xxxxxxxx





    If you are still having problems signing up please contact a member of our support staff at [email protected]

    Thanks very much,

    Late Night Radio team

    Is this a vBulletin problem, or is it my hosts problem?

    Thanks,
    Neal
    Last edited by Drile; Fri 7 Nov '03, 9:41pm.
    -Neal

  • #2
    It's a server problem:

    unrouteable mail domain "hotmail.com"
    You'll need to contact your host about this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      It's a server problem:


      You'll need to contact your host about this.
      I have submitted a ticket to my host, and provided a link to this thread. Thanks for the quick answer.

      Off the top of your head, do you have any suggestion as to what might be causing this problem? I don't understand how it could be sending the email out to me, but if it gets sent to any address other than [email protected] it doesn't work, and I get that Failed Delivery message.
      -Neal

      Comment


      • #4
        AFAICT the mail server is not properly configured to send email to any outside domains.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          AFAICT the mail server is not properly configured to send email to any outside domains.
          Thank you.

          I'll send another message to my host.
          -Neal

          Comment


          • #6
            My host replied with this, when I told them that you said that the mail server is not configured properly.

            Any advice you can give me, or can you recommend me anything else to tell them? (I really appreciate you helping me at all with this, because I understand it it not a "real" vBulletin issue.)

            Can you ask how to configure it in order to send mail to outside domains? Because from what I can see, it is already set to allow relaying to outside domains. Maybe Vbulletin needs some kind of special configuration?

            In Vbulletin is there a choice whether to use the local sendmail prog or the local SMTP server?
            -Neal

            Comment


            • #7
              vB does not need any special configuration. It uses PHP's mail() function. If PHP and the mail server are both configured correctly, then email will work.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I just noticed something.

                If I change the email address from which all emails from vBulletin are sent through to my main address xxxxxxxx@msn.com then it works fine. I only get the problem when I use my [email protected] address.

                I would prefer not to have to use my [email protected] address because that is my personal email. Any address with 2

                I am just posting this here aswell in case anyone else has ever had this problem, and can lend a hand.
                -Neal

                Comment


                • #9
                  This is still a server issue. You should let your host know about this.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X