Announcement

Collapse
No announcement yet.

Email Templates Switching (by themselves) Between Originals and Edited

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Templates Switching (by themselves) Between Originals and Edited

    vB 2.3.2
    PHP version 4.3.3
    MySQL version 3.23.58
    Apache version 1.3.28
    Linux operating system
    No hacks
    Yes minor changes to some templates
    ====================================

    I made minor changes to some of the default templates, including the email templates involved in notification of new users and notification of new posts -- namely the following templates:

    * email_activateaccount -AND- emailsubject_activateaccount

    * email_moderator -AND- emailsubject_moderator

    * email_newuser -AND- emailsubject_newuser



    Today, I spent some time creating new styles that combine new replacement sets with the default template set. At one point, I accidentally added a second default template set, and then I deleted it. Afterwards, I double-checked to make sure the sole existing default template set still contains my changes.

    Now, my emails are behaving erratically. For example, sometimes the original email_newuser template is used... and sometimes the changed email_newuser template is used. I don't know why.

    Please, any ideas?
    Thanks,
    Still Waters

  • #2
    Did you make the same change to all your template sets?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      Did you make the same change to all your template sets?
      No. Continuing with the example of the email_newuser templates, here are my edited versions:
      emailsubject_newuser
      Needs Your Okay: $username

      email_newuser
      New User: $username
      Profile: $bburl/member.php?action=getinfo&userid=$userid
      Email Address: $email
      Homepage: $homepage
      Birthday: $birthday
      $customfields
      You can see that the changes are particular only to those templates -- not the sort of changes that apply to all the templates.
      Thanks,
      Still Waters

      Comment


      • #4
        Not sure I understand what you mean. I suggest making the same change to all your template sets. Tnhis manes change all the email_newuser templates to the same thing, etc.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I'm sorry, I misread your previous post. I thought you asked, "Did you make the same change to all your templates?"

          In fact, you asked, "Did you make the same change to all your template sets?"

          The answer is, I have only one template set -- the default set. I did accidentally create another default set (while working on the new styles), but I then deleted it.

          Being that this is a transient problem -- and difficult to diagnose -- let me see how my emails are coming in, during the course of today. If I'm still having the same problem, I'll bump this thread. (I value your time.)
          Thanks,
          Still Waters

          Comment


          • #6
            Honestly then, I don't see how this could happen with the default (i.e., unhacked) vB. Also since you mentioned you were making new 'styles' the assumption was that this involved more than one template set.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I understand your assumption about the template sets. No problem.

              Here's an update. The emailsubject_moderator and email_moderator templates seemed to switch back-and-forth, again.

              In other words, I received 5 "new post" emails in succession: an edited email, then an original email, then an edited email, then an original email, then an edited email. Each of these five emails contained info for different posts -- no duplicates.

              Steve, is it possible for you to try trouble-shooting this without temporarily closing the board, if I provide you with an admin username and password? (I don't want to interrupt the forum users, as they're just beginning to settle down.) Thanks.

              Edited... just to remove my signature.
              Last edited by Still Waters; Mon 27 Oct '03, 1:17pm.
              Thanks,
              Still Waters

              Comment


              • #8
                Sorry but with all the official support required for vB 2.x I won't have time to do this right now. Again I don't see how this could happen unless some of the code was changed.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  By "official support," do you mean the support tickets? I'm ready to submit a ticket. I don't have any hacks.
                  Thanks,
                  Still Waters

                  Comment


                  • #10
                    Since vB3 is still in beta stage, at this time the official support system is for vB2 only.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I submitted a ticket for my 2.3.2 board.
                      Thanks,
                      Still Waters

                      Comment


                      • #12
                        And Martin responded a few minutes later.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          I solved the problem. Get ready for a bizarre story.

                          I logged in and selected every style, one by one. For each style, I posted a message and waited for the "new post" email. For each "new post" email, I noted whether the email had been produced by the original template or by the edited one. In this way, I identified exactly which styles were troublesome.

                          Next, I double-checked the number of template sets that existed on my board. There was only one template set listed, named "default."

                          Next, I double-checked the properties for every style. Every style contained a template set with the same name, "default."

                          Next, I created a new template set, called "dummy."

                          Then, I returned to the styles that I had already identified as troublesome. For each of those styles, I changed the template set to the "dummy" set -- saved the new properties -- and then I changed it back to the "default" template set -- and saved the properties again. Then, I made a new post and awaited the "new post" email.

                          In every instance, the problem had disappeared. In other words, the edited email template was now used, every time.

                          I can only conclude that (as bizarre as it sounds) there were apparently two template sets, both named "default." But one was the orignial templates and one was the edited templates.

                          Martin seems to agree with my conclusion, when he says, "That's likely the problem. I'm glad it's squared away!" Bizarre, huh?
                          Thanks,
                          Still Waters

                          Comment


                          • #14
                            Then it looks like I was right. You had more than one temoplate set and you didn't make the changes to all the sets like I asked.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol
                              Then it looks like I was right. You had more than one temoplate set and you didn't make the changes to all the sets like I asked.
                              lol, okay, you were right.

                              There were two template sets being used by the board. However, for all intents and purposes, only one template set was accessible (or even visible) in the admin cp. It was only by deduction that I determined there were, indeed, two template sets.
                              Last edited by Still Waters; Tue 28 Oct '03, 4:32am.
                              Thanks,
                              Still Waters

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X