Announcement

Collapse
No announcement yet.

moving servers --- error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • moving servers --- error

    we are in the process of moving to a new server.

    the db has been moved and i am now installing vbulletin on the new web server and i am getting errors while running the install.php3 file.

    i fixed a few errors but here is my latest:
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user: '[email protected]' (Using password: YES) in /hsphere/local/home/sculpted/sculptedbyiron.com/forum/admin/db_mysql.php3 on line 40

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /hsphere/local/home/sculpted/sculptedbyiron.com/forum/admin/db_mysql.php3 on line 47

    can anyone shed some insight into this error. obviously i am not an mysql person.

    btw - any tips on moving to a new server?

  • #2
    That error means at least one piece of information in your admin/config.php file is wrong. Contact your host if you aren't sure what MySQL information to use.

    Also, you shouldn't need to run install.php when moving servers since the database should already be populated from the backup file you restored.

    Comment


    • #3
      thanks jakeman

      i could not find info on moving to a new server other than the telnet info.

      right now i have the php files moved to the new server and the db copied over and set up.

      is it just a matter of moving all the files and then editing the config file with the new info?

      Comment


      • #4
        If the files and database are on the new server, it's just a matter of putting the correct MySQL info in the admin/config.php file to connect the two.

        Comment


        • #5
          thanks - that is what i was thinking

          all info in the config.php3 file is correct and this is the error that i am getting:

          Warning: mysql_connect() [function.mysql-connect]: Access denied for user: '[email protected]' (Using password: YES) in /hsphere/local/home/sculpted/sculptedbyiron.com/forum/admin/db_mysql.php3 on line 40


          am i correct that the page is not seeing the db properly? as if the db is in a different path?

          or am i way off?

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X