Announcement

Collapse
No announcement yet.

Switched Servers, Rebooted, Big Problem!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Switched Servers, Rebooted, Big Problem!

    I moved my site from my Windows 2000 server to a new Windows 2003 Server I built. The move was very simple, everything went right besides when installing mysql on Win2K3 it put the my.ini file in the C:\Documents & Settings\Administrators\Windows folder. So I moved it to C:\Windows and all worked great.

    It ran perfect for about a 3 days then I installed smtp and rebooted, even though I didnt need to. I come back and mysql wont start right for unknown reasons. I got it working again after messing with the php.ini, turns out that PHP was ran as a ISAPI, so I fixed that and ran it as a CGI/EXE.

    So here I am now and I get a error that seems to be MySQL releated and I cant figure it out, my.ini is configured right. But its still looking in the C:\Documents & Setting Folder so I just edit it and move it to C:\Windows.

    Here is the error I get.

    Warning: mysql_connect(): Access denied for user: '[email protected]' (Using password: YES) in D:\inetpub\wwwroot\Zilvia.net\f\admin\db_mysql.php on line 40
    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.


    PS: I have also re isntalled MySQL and PHP. (Both Latest Editions, even from previous install)

    Problem can be found @

    http://www.zilvia.net/f/index.php

    THANKS!

  • #2
    I'll post the same message that I replied to your support ticket here.

    You need to check to make sure the database information in your admin/config.php is correct. If it is, make sure that the username listed in there has the appropriate permissions to access your database.

    Comment


    • #3
      Originally posted by Cary
      I'll post the same message that I replied to your support ticket here.

      You need to check to make sure the database information in your admin/config.php is correct. If it is, make sure that the username listed in there has the appropriate permissions to access your database.
      That file is the same as the old one and worked before so I know for a fact that isnt the problem. Just to be sure I double checked them again and changed the usernames and other settings and nothing worked. It seems like the username/password got corrupted.

      Any Ideas?
      Last edited by Zilvia; Tue 30 Sep '03, 6:39am.

      Comment


      • #4
        Originally posted by Zilvia
        That file is the same as the old one and worked before so I know for a fact that isnt the problem. Just to be sure I double checked them again and changed the usernames and other settings and nothing worked. It seems like the username/password got corrupted.

        Any Ideas?
        Nevermind, I got it running. Thanks!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X