Announcement

Collapse
No announcement yet.

Access denied for user:

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Access denied for user:

    Okay, I had Interland setup a MySQL database for me. Now, when trying to install I get the following error message. The config contains all the right information. I issued a trouble ticket with Interland to see if I have to specify a location for the server aside from listing it as "localhost".

    Other than that what could I be doing wrong?


    Attempting to attach to database...

    Warning: Access denied for user: '[email protected]' (Using password: YES) in /usr/local/www/vhosts/djshadowforum.com/htdocs/forum/admin/db_mysql.php on line 40

    Warning: MySQL Connection Failed: Access denied for user: '[email protected]' (Using password: YES) in /usr/local/www/vhosts/djshadowforum.com/htdocs/forum/admin/db_mysql.php on line 40

    Warning: Supplied argument is not a valid MySQL-Link resource in /usr/local/www/vhosts/djshadowforum.com/htdocs/forum/admin/db_mysql.php on line 47

    The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

    Click to go to the vBulletin website
    Diesel Records

  • #2
    Obiously, one of the variables set in config.php are wrong - either the database username or the database password - else your account has no access to the database you are trying to use.

    Comment


    • #3
      If you are using cPanel, make sure you add that user to the Database. Creating a new DB user doesnt automatically add him to the database access.
      @[email protected]

      Comment


      • #4
        I am having the same problem, how I can add the user? there is no box for that

        thanks

        Comment


        • #5
          If you have CPanel, click on MySQL.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Also make sure (with cpanel) your database name INCLUDES your account name.

            Like if you make a new db, and call it "vb". And lets say your Cpanel account name is "joeshmo".

            Your database name is: joeshmo_vb
            Same with username... (not password though!).
            Owner of VB! :cool:
            "Life is good in the valley!"
            IP Tab it!

            Comment


            • #7
              Warning: mysql_connect(): Access denied for user: '[email protected]' (Using password: NO) in e:\Websites\xakras.org\forums\admin\db_mysql.php on line 34

              Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in e:\Websites\xakras.org\forums\admin\db_mysql.php on line 47


              The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

              I don't have cpanel.
              i tried putting in the user name and pw for my website admin stuff, didnt work.
              went back to the defaults of root and no pw.
              still no luck,

              k, i'm new at this,
              but i've tried it 7 ways from sunday, doesnt seem to work,
              and I don't see anyway to try what's been suggested above.

              help please?

              Comment


              • #8
                Is it a unix/lunix machine? You have it config'd for a windows box....

                Warning: Access denied for user: '[email protected]' (Using password: YES) in /usr/local/www/vhosts/djshadowforum.com/htdocs/forum/admin/db_mysql.php on line 40

                And thats unix.. make yer mind up. :P
                Owner of VB! :cool:
                "Life is good in the valley!"
                IP Tab it!

                Comment


                • #9
                  This error means either:

                  1. One or more of the following is wrong in your config.php file:

                  $dbusername
                  $dbpassword
                  $dbname

                  If you are unsure of what the appropriate values are then you will need to ask your web host.

                  2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    mine is windows, not unix

                    i'm thinking at this point, i need to set up a db.
                    i tried seeting one up, jook_db.php but that didnt work

                    <?php
                    // set your infomation.
                    $dbhost='localhost';
                    $dbusername='jook';
                    $dbuserpass='XXXXX';
                    $dbname='jook_db';
                    // connect to the mysql database server.
                    $link_id = mysql_connect ($dbhost, $dbusername, $dbuserpass);
                    echo "success in database connection.";
                    // create the database.
                    $dbname=$dbusername."_".$dbname;
                    if (!mysql_query("CREATE DATABASE $dbname")) die(sql_error());
                    echo "success in database creation.";
                    ?>

                    everything seems to be really close to working,
                    but....

                    Comment


                    • #11
                      Thanks for the help,

                      i needed to have my host set up my connection to mysql, and set up a starter db.

                      A friend that runs a vb mb, looked at my site, my install, and confirmed that was needed

                      changed to canidate 2, and got it all installed.
                      still sorting thru all the options

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X