Announcement

Collapse
No announcement yet.

I keep getting this error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I keep getting this error

    Anybody know why this error keeps popping up?


    Warning: mysql_pconnect(): Too many connections in /home/lawncafe/public_html/admin/db_mysql.php on line 38



    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.

  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

    Here is more info on that error:

    http://www.mysql.com/doc/T/o/Too_many_connections.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

      PHP Code:
      // use persistant connections to the database
      // 0 = don't use
      // 1 = use
      $usepconnect 0
      But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

      Here is more info on that error:

      http://www.mysql.com/doc/T/o/Too_many_connections.html
      i just opened my site up to the members yesterday and had maybe 25 of those messages in my email box.

      i'll make the suggested changed to my config.php file before putting in a trouble ticket to my host.

      thanks for the advice!

      Comment


      • #4
        Thanks!

        this aparently fixed the error, thank you very much!

        Comment


        • #5
          Originally posted by joeydood
          this aparently fixed the error, thank you very much!
          mmm, not so fast, young jedi... more errors in my mailbox yesterday 'could not connect'... something like that.

          Comment


          • #6
            Originally posted by joeydood
            mmm, not so fast, young jedi... more errors in my mailbox yesterday 'could not connect'... something like that.
            As Steve said, you will now have to contact your host to increase the number of connections.

            Comment


            • #7
              Originally posted by poolking
              As Steve said, you will now have to contact your host to increase the number of connections.
              will do man! thanks!

              Comment


              • #8
                I e-mailed the server and it was corrected.

                Thanks.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X