Announcement

Collapse
No announcement yet.

Moving Server Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moving Server Problems

    Hello all

    Wonder if someone can please give me a little advice, I am trying to move my forum (vb2.8) to a new server.

    This is the procedure I took.

    I have made a identicle copy of the php files from my original FTP and copied it to the new FTP keeping the directory stucture.

    Made a backup of the sql database via SSH which backed up to the html directory of my ftp and the sql was gzipped.

    I then downloaded the backup and uploaded the backup the html directory of the new ftp and used ssh to unzip and connect to the new database.

    So after all that everything seemed fine BUT when I log in it won't keep me logged in, soon as I move about within the forum it gives me the login screen again and if I try login to admin it just refreshes the page and brings me back to login but if I put in the wrong username or password it takes me to the usuall wrong details screen.

    So can anyone please tell me what I am doing wrong? I have a number of hacks installed on my server but I thought as I made a 100% identicle backup that it would not be a problem?

    Any ideas?

    Thank you

    Kruger

  • #2
    It sounds like you have a Cookie Domain and Path setting in the db that is not compatible with the new domain and/or server.

    Run this query:

    SELECT * FROM template WHERE title='options'

    Locate the appropriate variablea (cookiedomain and cookiepath) in this format:

    $varname = 'value';

    Change the settings to blank and / respectively. Then also make the same change to your setting table.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thank you very much Steve!! I was crackin' my head with this darn problem!!!!

      I really appreciate it!

      (hey! the "search" feature sure works! )

      Comment


      • #4
        Sorry yes I should have also said this sorted me out too, great job, thanks.

        Comment


        • #5
          there's a problem. now every certain time the old path for cookies returns!!
          my forums were on http://forums.flightsimmer.com I've erased the cookies path as you said (to blank from "forums.flightsimmer.com"), but every certain time THIS THING RETURNS TO FORUMS.FLIGHTSIMMER.COM!!!!

          What else can I do?

          Thanks in advance!

          Comment


          • #6
            After making this change in the database, go into the Admin CP and change it there as well. Then save the changes. The problem is that this is still cached in the settings table I believe.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              darn that was fast!! thanks again Steve!!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X