Announcement

Collapse
No announcement yet.

forum upload error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • forum upload error

    have a user trying to upload a 1.5mb rar file. rar is a valid extension.

    Max file size in the cp is set at 4mb

    phpinfo - upload_max_filesize = 2mb
    post_max_size = 8mb
    user tries to upload and gets the following errors:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 1587413 bytes) in /data/......../forums/admin/db_mysql.php on line 226

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 35 bytes) in /data/..../forums/admin/functions.php on line 2382

    Any ideas?

    Thanks

  • #2
    bump

    bump

    Comment


    • #3
      You may need to increase the memory_limit variable in php.ini. Restart Apache after making the change.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        hmmmm

        memory_limit is set to 8mb and the file size is 1.5mb.

        As a test, I wrote my own php program to allow file xfer, and the .rar file is successfully uploaded to a temp dir (same permissions) using my program. But, when attaching to a post the above error is returned.

        This has me baffled!!!!

        Comment


        • #5
          Your memory limit of 8Mb isn't enough as per the error message you got. Try increasing it to 16Mb.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X