Announcement

Collapse
No announcement yet.

upgrade from hell

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade from hell

    just upgraded my board to 2.3.2.
    after the upgrade i decided to revert all template back to default, so i deleted all the replacement sets, templates, and then reloaded the vb.style and added new default replacement sets..

    Well, my main front page relies on the vb template engine, and now i get these messages:


    Database error in vBulletin 2.3.2:

    Invalid SQL: SELECT template FROM template WHERE title='index_header3' AND (templatesetid=-1 OR templatesetid=9) ORDER BY templatesetid DESC LIMIT 1
    mysql error:

    mysql error number:


    AND:


    Invalid SQL: UPDATE session SET lastactivity=1061246301,location='/',styleid=1 WHERE sessionhash='4890b90ebfaaf8a1e533629d4fe7e1be'
    mysql error:

    mysql error number:


    how can i fix this?

  • #2
    1. Upload the vbulletin.style file from the zip file to your admin directory. Make sure you upload in ASCII and overwrite the one on the server. Then use the Styles Download/Upload function to 'Import existing style set'. Choose 'No, create a new style', then click on 'Import File'.

    2. If you still have the session problem, run this query in phpMyAdmin:

    DELETE FROM session;

    If that doesn't work, run this one:

    DROP TABLE session;
    CREATE TABLE session (
    sessionhash char(32) NOT NULL,
    userid int(10) unsigned DEFAULT '0' NOT NULL,
    host char(50) NOT NULL,
    useragent char(50) NOT NULL,
    lastactivity int(10) unsigned DEFAULT '0' NOT NULL,
    location CHAR (255) not null,
    styleid smallint(5) unsigned DEFAULT '0' NOT NULL,
    althash CHAR (32) NOT NULL,
    PRIMARY KEY (sessionhash)
    ) TYPE=HEAP;
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      nope.. still.
      Database error in vBulletin 2.3.2:

      Invalid SQL: SELECT template FROM template WHERE title='index_header3' AND (templatesetid=-1 OR templatesetid=9) ORDER BY templatesetid DESC LIMIT 1
      mysql error:

      mysql error number:

      -------------------------------------------------------------
      Database error in vBulletin 2.3.2:

      Invalid SQL: UPDATE session SET lastactivity=1061247672,location='/' WHERE sessionhash='7574910cec5491c698c4aaf31ca957c1'
      mysql error:

      mysql error number:

      Comment


      • #4
        well, i guess i'm going to have to go back to 2.3.0 RC.. as they say dont try to fix something that isn't broke..

        Comment


        • #5
          Maybe i did something wrong when upgrading..

          on the upgrade page it says


          From 2.3.0 Release Candidate 1, Release Candidate 2 or Release Candidate 3
          Run http://your.site/forums/admin/upgrade23.php again, clicking the link that allows you to continue when the script alerts you that you have already run this script.



          i am running 2.3.0 RC (dont remember which RC it is...)
          So upgrading from 2.3.0 RC, I have to run just upgrade23 and thats it?

          or upgrade23,upgrade24, and upgrade25 ???
          the upgrade manual does not say anything about running these other files..

          See the image attached, a style number has changed in global.php and i think that is causing my template DB error..


          Please advise ASAP, my site is down and i have 400 users waiting.
          Attached Files
          Last edited by sebe; Mon 18 Aug '03, 5:56pm.

          Comment


          • #6
            To upgrade from any version of 2.3.0 to 2.3.2, you need to run the following upgrade scripts in this order:

            upgrade23.php
            upgrade24.php
            upgrade25.php
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X