Announcement

Collapse
No announcement yet.

Backup restoration problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backup restoration problem

    Hi.

    I wanted to make a nostalgia thread at the Eyes On Final Fantasy forums, which have been running vBulletin since the 1.x series, so I dug up an old site backup, containing an SQL dump of the database, and put it on a "server" running Windows 2000 Professional and the most up-to-date versions of MySQL and PHP. I had no problems importing the database, but all I can seem to view is the forums listing.

    The backup is running vBulletin 2.0.0 Release Candidate 2, if that's of any value.

    I also cannot log in, although I've manually looked at the database and confirmed that my password is right; I've also tried logging in as all of the other administrators of the time. I even verified my usergroup, since that backup was taken not long after I was made an admin.

    I tried to use that db with 2.3.0. predictably, it didn't work; I was just faced with a WPoD.

    Next, I tried to upgrade the 2.0.0 RC2 database up to 2.3.0. I had to do some digging through the backup CDs to find all those upgrade scripts, but I found them--upgrade1 all the way up to 23. Upgrade8.php was the one I was looking for, so I tried to run it, and I was faced with an administrator login screen...and once again, my user/pass didn't work, and neither did that of any other administrator in the system.

    If it's of any assistance, I can upload the database dump to EoFF's server, but it's a 48 meg text file. (Security issues are nil at this point; The db dump was taken in May, 2001, and if anybody hasn't changed their password by now, they deserve to get their accounts hijacked . Plus, I'm pretty sure that aside from the board owner, who isn't around anymore, I'm the only admin from then who is still on staff)

    It's not enough to simply see the posts; I can do that by viewing the SQL dump in a text editor; I want to actually display them with the vBulletin software so that I can save key threads as .mht files and post them on the current, live forum.

    (Sorry, I can't allow anybody to access the test forum directly, as it is protected by an ISA server and cannot accept incoming connections from outside of my LAN)

    EDIT: Details:
    -When I attempt to view a person's profile, I get the password recovery form, which does not work (Fatal error: Cannot redeclare stripslashesarray() (previously declared in c:\inetpub\wwwroot\forums\global.php:10) in c:\inetpub\wwwroot\forums\global.php on line 10
    )
    -When I attempt to open a forum, I get the error "No forum specified. If you followed a valid link, please notify the webmaster"
    -When I attempt to log in (Using a correct password), I get the password recovery form, which does not work
    -when I attempt to access the admin control panel, it just keeps sending me back to the login box

    Perhaps the database dump and the forum file backup were taken at a different time? I doubt it, though.
    Last edited by Citizen Bleys; Tue 15th Jul '03, 11:31am.
    Mark S. Huculak, CNA, MCP

  • #2
    No need to dig through cd's to find those upgrade scripts.
    The latest build (2.3.0) holds all those scripts in the admin/. folder.

    Comment


    • #3
      14-23 in *my* archive. At any rate, that's not the problem; I had enough archive CDs to reconstruct upgrade1 right through to 23...the problem is that the backup board isn't recognizing my password, and I'm sure it's right because passwords were stored as plain text in those days, so all I had to do was read the db.
      Mark S. Huculak, CNA, MCP

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X