Announcement

Collapse
No announcement yet.

Usage for calendar ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Usage for calendar ?


    I'm using vB 2.3.0.
    My vB is 2 weeks old.
    When I click on calender ( between 'user cp' and 'member').
    I get the following error from the
    set-error_handler('myErrorHandler') in calendar.php.

    My question: is there some initial step I have to do for
    calendar.php to work ?

    The error msg are:

    Error: Undefined index: HTTP_POST_VARS
    Error occurs in line 115 in file: /web/prod/forums/global.php
    Error: Undefined index: action
    Error occurs in line 115 in file: /web/prod/forums/global.php
    Error: Undefined index: action
    Error occurs in line 118 in file: /web/prod/forums/global.php
    Error: Undefined variable: debug
    Error occurs in line 130 in file: /web/prod/forums/global.php
    Error: Undefined index: bbalthash
    Error occurs in line 29 in file: /web/prod/forums/admin/sessions.php
    Error: Undefined index: lastactivity
    Error occurs in line 369 in file: /web/prod/forums/admin/sessions.php
    Last edited by hsiaok; Tue 15th Jul '03, 9:30am.

  • #2
    Admin CP -> vBulletin Options -> Calendar -> Enable Calendar

    If you still have a problem then reupload the original vB files.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Enable/disable

      Originally posted by Steve Machol
      Admin CP -> vBulletin Options -> Calendar -> Enable Calendar

      If you still have a problem then reupload the original vB files.
      ==================
      I've tried copy the original forums/calendar.php and
      with calendar enable or disable, I get the same result.

      Error: Undefined index: HTTP_POST_VARS
      Error occurs in line 115 in file: /web/prod/forums/global.php



      One more thing:
      if I comment out
      //=====================================
      function myErrHandler ($errno, $errstr, $errfile, $errline) {
      echo "<br> Error: $errstr
      <br> Error occurs in line $errline in file: $errfile";
      }
      set_error_handler('myErrHandler');

      from forums/calendar.php
      then it hang and I get an blank page from IE.



      I tried calendar.php with
      foreach($HTTP_GET_VARS as $key=>$val) echo "$key = $val<br>\n";
      foreach($HTTP_POST_VARS as $key=>$val) echo "$key = $val<br>\n";
      =================================
      I get:
      get var belows = 0a31c5ffa9c17c082aef43a7b84376e2
      post var below
      ======================================
      which is saying
      array $HTTP_GET_VARS has only s for session
      and $HTTP_POST_VARS is empty.

      and this is why line# 113 in global.php is saying:
      Error: Undefined index: HTTP_POST_VARS
      ======================================
      Am I right in the above testing/observation ?
      Can someone shed some light on this ?
      What have I done that cause this error ?
      Last edited by hsiaok; Tue 15th Jul '03, 9:28am.

      Comment


      • #4
        Reupload all the original vB files.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Original vB filoe

          Originally posted by Steve Machol
          Reupload all the original vB files.
          I've done 'upload all the original file' once before.
          And I have to chop up user.php because otherwise
          I can't get it to work.

          Other than user.php, I've no modified any other file.
          I don't have any motive to modify any other file.

          Should I put reinstall vB
          on http://www.losangeles.af.mil as I did before
          so you can see what my problem is ?
          What do you think ?

          Comment


          • #6
            I don't know what you mean by 'as I did before'. Did you have this problem or a similiar problem before?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I had reinstalled before

              Originally posted by Steve Machol
              I don't know what you mean by 'as I did before'. Did you have this problem or a similiar problem before?
              Do you remember this thread ?
              http://www.vbulletin.com/forum/showthread.php?t=76211

              Comment


              • #8
                No sorry I don't. I deal with hundreds of threads and support tickets every day and don't have total recall of them all. Besides it looks like eva2000 was working with you on that one.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  eva2000

                  Originally posted by Steve Machol
                  No sorry I don't. I deal with hundreds of threads and support tickets every day and don't have total recall of them all. Besides it looks like eva2000 was working with you on that one.


                  I can understand that you deal with lots of user.

                  eva2000 told me that they don't know of any one
                  using Netscape Web Server on Sun Solaris
                  and suggest that I try to install Apache to find out
                  whether the problem is because web server is incompatible with
                  vB.
                  It's a long procedure to install install php and Apache, so
                  I havn't try that yet.

                  Let me ask you this question:
                  when the mouse is on calendar from my IE browser with URL:
                  http://www.vbulletin.com/forum/newre...reply&p=495073
                  the status var says:
                  http://www.vbulletin.com/forum/calendar.php?


                  but th status bar content is this for this URL:
                  http://intranet.losangeles.af.mil/fo...ndar.php?s=xxx
                  ( where xxx is session id).
                  Why is the difference ?

                  Comment


                  • #10
                    In the latter case you are not using cookies to browse your forums.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      action 'add' for calendar.php

                      I found answer to my own question.
                      Never mind.

                      Comment

                      Loading...
                      Working...
                      X