Announcement

Collapse
No announcement yet.

Quote Function - HELP!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quote Function - HELP!

    What's the code replacement supposed to be when looking at it through the Admin CP?

    The reason I ask is that we've had users complaining that they cannot use the quote function button as it only takes the first letter from the last person's message that they want to quote.

    Please reply with the quote code replacement. It would be most helpful.

    Regards,

  • #2
    vB Code tag - quote
    vB Code replacement - <blockquote><smallfont>quote:</smallfont><hr>{param}<hr></blockquote>
    vB Code example - [ quote]This is a quote[ /quote]

    vB Code explanation - The quote tag is used to denote a quote from another post
    Use {option} ? - No

    Remove the spaces in the tags for the vB Code example.

    Comment


    • #3
      Originally posted by Jakeman
      vB Code tag - quote
      vB Code replacement - <blockquote><smallfont>quote:</smallfont><hr>{param}<hr></blockquote>
      vB Code example - [ quote]This is a quote[ /quote]
      vB Code explanation - The quote tag is used to denote a quote from another post
      Use {option} ? - No

      Remove the spaces in the tags for the vB Code example.
      Where in the newreply.php does the quote function come into play? It's not the Custom Quote code that's referenced in the Admin CP causing the problem.

      Comment


      • #4
        vB Codes are parsed in the bbcodeparse() function in the admin/functions.php file.

        Can you post a URL to a post on your forums with this problem?

        Comment


        • #5
          Thank you in advance.

          Here's the snippet from the newreply.php which I would like to confirm if it's correct or not:

          Code:
          $postdate=vbdate($dateformat,$postinfo[dateline]);
          	$posttime=vbdate($timeformat,$postinfo[dateline]);
          	$pagetext=$postinfo[pagetext];
          	$pagetext = trim(preg_replace("/(\[quote])(.*)(\[\/quote])/siU", "", $pagetext));
          	eval("\$message = \"".gettemplate("quotereply",1,0)."\";");
            }
          }
          Here's the functions.php:

          Code:
          $replacearray = array(
          		  "<ol type=\"[url="file://\5\"]\\5\">\\7</ol[/url]>",
          		  "<ul>\\4</ul>",
          		  "<li>",
          		  "<a href=\"[url="http://www.\6"]http://www.\\6\[/url]" target=\"_blank\">\\8</a>",
          		  "<a href=\"[url="file://\5"]\\5\[/url]" target=\"_blank\">\\7</a>",
          		  "<a href=\"[url="http://www.\5"]http://www.\\5\[/url]" target=\"_blank\">\\5</a>",
          		  "<a href=\"[url="file://\4"]\\4\[/url]" target=\"_blank\">\\4</a>",
          		  "</normalfont><blockquote><pre><smallfont>code:</smallfont><hr>\\5<hr></pre></blockquote><normalfont>",
          		  "</normalfont><blockquote><pre><smallfont>code:</smallfont><hr>\\5<hr></pre></blockquote><normalfont>",
          		  "java script:",
          		  "about :",
          		  "vbscript :"
          		);
          Code:
          if (floor($phpversionnum) < 4) {
          	  // get rid of stray <br> tags in the code - upsets older browsers (IE 4.72 reported problems)
          	  $codebits=explode("</normalfont><pre><smallfont>code:</smallfont></normalfont><hr><blockquote>",$bbcode);
          	  list($key,$bbcode)=each($codebits);
          	  while (list($key,$val)=each($codebits)) {
          		$sbbits=explode("</blockquote><hr></pre><normalfont>",$val);
          		$newbits=str_replace("<br>", "", $sbbits[0])."</blockquote><hr></pre><normalfont>".$sbbits[1];
          		$bbcode.="</normalfont><pre><smallfont>code:</smallfont></normalfont><hr><blockquote>".$newbits;
          	  }
          	}
            }

          Comment


          • #6
            I really need to see the error first.

            If you have any file hacks installed, try uploading the originals from the vBulletin zip file.

            Comment


            • #7
              Check this link out

              http://www.futurelooks.com/forums/sh...1477#post71477

              Comment


              • #8
                I can't access that link.

                I registered under the name Jakeman and clicked the activation link in the email I was sent, but I still can't access that link. I am told I don't have permission. Is that post in a restricted forum?

                Comment


                • #9
                  One of our moderators was quick to move it Jakeman.

                  Try it at this link: http://www.futurelooks.com/forums/sh...?threadid=6122

                  I've moved it to a less busy section of our forum.

                  Comment


                  • #10
                    Wow that's weird.

                    Send me a PM with a FTP login for your server. From there I can check your files and gain access to your Admin CP to check your templates.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X