Announcement

Collapse
No announcement yet.

Cookie problem again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    He did not manually delete his cookies. To do this in IE 6.0:

    Tools -> Internet Options -> Temporary Internet Files -> Settings -> View Files

    Then search for the individual cookies for your domain and delete them all. The name should be in the form of:

    Cookie:[email protected]
    and
    Cookie:[email protected]www.yoursite.com

    ...and any derivatives of the above. Then highlight the individual cookies and delete each one found. After this, close all browser windows and restart IE.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      What about the users who just registered and get this?

      Comment


      • #18
        Erm...... is it possible that by exporting my current database to a new one this will stop incase my session table may be messed up?

        Comment


        • #19
          I really don't know the answer to either of your questions. Have you installed any hacks? Have you made any changes to your Cookie Domain and/or Path? These problems are definitely not normal.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            Originally posted by Steve Machol
            I really don't know the answer to either of your questions. Have you installed any hacks? Have you made any changes to your Cookie Domain and/or Path? These problems are definitely not normal.
            I have some hacks installed, but none of these issues started until I emptied he session table.

            I changed the cookie domain after I emptied the session table, but it doesn't matter because either domain works. (used to be .teenadvicecenter.com and i changed it to .tac.theforumhost.com)

            The queries I manually had to run when installing these two hacks: (mind you, these have been installed awhile now, long before these issues)

            ALTER TABLE user ADD usecensor TINYINT(1) DEFAULT '1' not null AFTER coppauser

            alter table user add miserable smallint(5) unsigned DEFAULT 0 NOT NULL;

            And unless the reported posts center runs queries when you run the installer, those are the only database alters that are still there AFAIK.

            Comment


            • #21
              Argh! I had to log out to test something, and it wouldn't log me out, so I manually deleted my cookies (Mac OS X) and now it won't let ME stay logged in.

              Can I fill out a support ticket even though I have hacks?

              Comment


              • #22
                Sorry. You'll need to remove your hacks and reupload the original files first.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #23
                  Originally posted by Steve Machol
                  Sorry. You'll need to remove your hacks and reupload the original files first.
                  Why? I seriously doubt it's a file because it was fine until I emptied the stupid session table.

                  Would emptying it again help? I never emptied it after changing my cookie domain.... could that be why?

                  Comment


                  • #24
                    Because we don't provide official support for forums running code that we didn't write.

                    Why did you change the cookie domain? That is very rearely needed. Every time you do this you run the risk of messing up your cookies and causing login problems. Manually delete all the cookies for your domain then restart your browser. If you still have problem then try emptying your session table again.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #25
                      Originally posted by Steve Machol
                      Because we don't provide official support for forums running code that we didn't write.

                      Why did you change the cookie domain? That is very rearely needed. Every time you do this you run the risk of messing up your cookies and causing login problems. Manually delete all the cookies for your domain then restart your browser. If you still have problem then try emptying your session table again.
                      If I change the cookie domain back will it work?

                      Comment


                      • #26
                        I fixed it.....

                        http://teenadvicecenter.com = parked domain

                        http://tac.theforumhost.com = raw domain (one assigned upon switching to this host)

                        Using http://teenadvicecenter.com would not log me in.

                        Using http://tac.theforumhost.com it does.

                        The cookie domain USED to be .teenadvicecenter.com, and both urls would log you in.

                        The cookie domain is NOW .tac.theforumhost.com and only http://tac.theforumhost.com logs you in.

                        Will setting it back to .teenadvicecenter.com let both urls work again?

                        Comment


                        • #27
                          No. Cookies can only be used on the domain they were created with. As I said before you should leave the cookie domain blank.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #28
                            Originally posted by Steve Machol
                            No. Cookies can only be used on the domain they were created with. As I said before you should leave the cookie domain blank.
                            Will leaving the DOMAIN blank fix all this?

                            Comment


                            • #29
                              I can't guarantee it since you may have other problems by now (corrupted cookies, bad sessions, etc.) but it certainly won't hurt.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X