Announcement

Collapse
No announcement yet.

User Password not reset when requested

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SloppyGoat
    replied
    Exactly the same problem. Did anyone ever solve this? I checked the useractivation table in my database, and my password reset request is there, too. There are others, also. What would happen if I flushed this table? Anything bad? Is it worth a shot?

    Leave a comment:


  • Scott MacVicar
    replied
    The entry into the useractivation table should never be made since the error is on the else branch of that block of code.

    If you can open a support ticket with phpMyAdmin access, ftp access and a fresh user account i'll have a look at this for you.

    Leave a comment:


  • StevenTN
    replied
    We had this problem as well with 2.2.6 and had tried to get support on this earlier, and since our boards were heavily hacked (and really couldn't go back to them at the time), we waited until the upgrade to see if that fixed the problem. Apparently, it didn't.

    Here's the exact route I followed...
    • Deleted the 2.2.6 php (since it was heavily hacked and loading slow)
    • Installed the 2.3.0 code (with the upgrade scripts, running upgrade20, upgrade21, upgrade22, and upgrade23, then deleted them as recommended. They ran without any problem). I reinstalled any hacks that we relied on the most (quick reply, our own coaster count hack, IRC online hack, etc.).
    • When I noticed the problem continued, I tried with a clean member.php just to be safe. No avail.
    • I then reverted the e-mail templates. No avail.
    • Since some hacks (a few small ones that I know won't affect performance) have been reinstalled I attempted a password reset using our test installation (which is clean)... no avail.
    • I also tried with different web browsers just to make sure.
    • I checked the useractivation table in our database... it's there, and my password reset request is there.
    • Other users on our site have reported this problem
    So basically, I'm at a loss. FYI: Our coaster count hack has been on for a year now (we installed it when we put in 2.2.6). The password reset worked up until March. Coming to think about it, user activations failed around then too, but we disabled it after we found out.

    FYI: We have Apache 1.3.27, PHP 4.3.1, and MySQL 3.23.52 (if that's any help).

    Leave a comment:


  • Steve Machol
    replied
    I moved your post to it's own thread so it didn't get confused with the other person's problem.

    I am not clear on what you have done exactly. This doesn't appear to be the proper way to upgrade from 2.2.6 to 2.3.0. The correct procedure is here:

    http://www.vbulletin.com/members/upgrade.html

    Leave a comment:


  • StevenTN
    started a topic User Password not reset when requested

    User Password not reset when requested

    I am having the same problem We started to have the problem while we had vB 2.2.6. Since it was heavily hacked, we opted to install a fresh copy of 2.3.0 using the existing database. With that, we basically removed the /boards directory, and installed the fresh 2.3.0 code there.

    Here's what I've done
    - Reverted the e-mail templates to default
    - tried with a good, clean copy of member.php (the ZIP was uploaded, then unzipped)
    - tried with different browsers

    Still, we keep on getting this message anytime a user resets a password...

    The address that you have used to request a new password is not valid. Please request a new address be sent to you by using this form.

    Manually resetting passwords for everyone really isn't an option since I have other projects (both with ThrillNetwork as well as a few other sites and a real life job hunt).

    Any suggestions?

    EDIT: Forum installation is http://www.thrillnetwork.com/boards/

Related Topics

Collapse

Working...
X