Announcement

Collapse
No announcement yet.

Max. Characters Customfield?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Max. Characters Customfield?

    In the panel it says you may enter up to 250 characters per customfield.

    Is there a way to change that for some fields to 2500?
    KCi aka Rhyze

  • #2
    The field type for custom profile fields in the database is char(250). You can use a program like phpmyadmin to edit this to accomodate more characters. Look in the userfield table.

    Comment


    • #3
      Originally posted by Jakeman
      The field type for custom profile fields in the database is char(250). You can use a program like phpmyadmin to edit this to accomodate more characters. Look in the userfield table.
      So I can just change the 'maxlength' field from 250 to 2500 without doing any harm?
      KCi aka Rhyze

      Comment


      • #4
        yep, that should work. Then you can set the custom field to take more than 250 characters.

        Comment


        • #5
          Hey Guys

          This doesn't work.

          When I have changed two fields to 2500 in phpmyadmin, it does show up in the vb panel with my customfields, but when I start to enter data for these two fields I have set for 2500 it still gets truncated at 250.

          So what do I need to do more to use these fields I want to set to 2500?

          Please help.
          KCi aka Rhyze

          Comment


          • #6
            This is limited in the db. You would need to change the type and length for that field directly in the db.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              You edited the userfield.fieldnumber field? That should work.

              Comment


              • #8
                Originally posted by Jakeman
                You edited the userfield.fieldnumber field? That should work.
                Yes, but when I edit and save that field I get the following:

                Too big column length for column 'field11' (max = 255). Use BLOB instead

                I'm dunno at phpmyadmin so what do I need to do here to solve this?

                Can I just change the 'Field Type' to 'Blob' ?
                KCi aka Rhyze

                Comment


                • #9
                  You can, but then we can't guarantee that this field will upgrade properly to vB3.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol
                    You can, but then we can't guarantee that this field will upgrade properly to vB3.
                    I have a feeling that and upgrade for my site is not in the near future

                    This field is just being used by the board for 'Game Titles' that my members own.
                    So if this will not pickup with the upgrade they have to enter that again, this is not something they don't have to do everyday, only one time after the upgrade, or do I see this wrong?
                    KCi aka Rhyze

                    Comment


                    • #11
                      Mind you I'm not saying there WILL be a problem either. It's just that I've seen several upgrade problems that mentioned BLOB fields in the errors they were getting.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X