Announcement

Collapse
No announcement yet.

Install Problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install Problem?

    When I run the install.php and it gets to the "Attempting to attach to database..." page I get the following error:

    ++++++++++++++++++++++++++++++++++++++
    The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

    Click to go to the vBulletin website

    PHP Warning: unlink() [function.unlink]: Permission denied in E:\myweb.com_root\forums\admin\install.php on line 305 PHP Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user: '[email protected]' (Using password: YES) in E:\myweb.com_root\forums\admin\db_mysql.php on line 38 PHP Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\myweb.com_root\forums\admin\db_mysql.php on line 47
    ++++++++++++++++++++++++++++++++++++++

    I have installed MySQL and set it to run as a service, which it is doing, but I must be using the incorrect username or something? Any pointers?

  • #2
    You may have either A) Not installed mySQL properly, or B) Entered the mySQL DB information incorrectly.

    Comment


    • #3
      First, change $servername back to 'localhost'. If you still have this problem after that, this error means either:

      1. One or more of the following is wrong in your config.php file:

      $dbusername
      $dbpassword
      $dbname

      If you are unsure of what the appropriate values are then you will need to ask your web host.

      2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I followed the doc's on the mysql site; 2.1.2.3 Starting the Server for the First Time and it tested properly. Think its a username issue but I'm not familiar with MySQL to know how to trouble shoot it?

        Comment


        • #5
          You'll need to ask your host for the correct info.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I manage the box myself. (intranet)

            $servername currently is 'localhost'

            is there a way of checking users for MySQL from the DOS commmand to verify if this is a permissions problem?

            Comment


            • #7
              If there is, I don't know what it would be. Sorry.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Hey Steve
                I changed $dbusername to root and left the $dbpassword blank and it worked. I think this is the default user that is made during the MySQL installation process. Once I changed this it worked and I'm currently at the step that allows me to set up the options for my board.

                As this dosen't sound like a very secure way, do you know how I might change the default root password for MySQL and should I use a different username password combination other then the admin one for my board?

                Hope this makes sense. This is the first time with PHP and MySQL so I have a big learning curve.

                Comment


                • #9
                  You need to create a mysql user and password and assign that user to this database. I can only suggest you visit the MySQL home page for instructions on doing this:

                  http://www.mysql.com/
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Steve thanks for your patience and quick response. I’ll do some digging and maybe try posting a question to the MySQL board on vBulletin’s Community Forum.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X