Announcement

Collapse
No announcement yet.

Cannot upload attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot upload attachments

    New installation that has been up and running for the past 3 weeks. First time trying to upload an attachment for a thread.

    Cannot find information in the manual to help point me in the right direction.

    I can post the thread without the attachment just fine but not with the attachment.

    Corrected the vbulletin option for size of the file first. Now set to 10 mb for max. file size.

    Not sure where the actual attachments get placed in the directory structure of vbulletin or if this is a directory or user rights issue.

    Help.

    Thanks,

    Christopher M. Heffner

    http://cisco.certified-labs.com/phpinfo.php
    Christopher M. Heffner, CCIE, CCSI
    Strategic Network Solutions, Inc.
    www.certified-labs.com

  • #2
    What size file are you uploading? You may need to change the upload size for both PHP and for MySQL. You need to have root access to the server to do this. Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Still not working

      Originally posted by Steve Machol
      What size file are you uploading? You may need to change the upload size for both PHP and for MySQL. You need to have root access to the server to do this. Make these changes to php.ini:

      upload_max_filesize = xM

      ..and my.cnf

      set-variable=max_allowed_packet=xM

      Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.
      Steve,

      Still not able to attach files to the vbulletin system. Could this be a rights issue or a directory issue? I am not sure what directory this is uploading too or the rights that need to be assigned to that directory.

      Can you tell me what directory the attachments are uploaded too and what rights need to be assigned to the directory?

      Thanks,

      Chris Heffner
      Christopher M. Heffner, CCIE, CCSI
      Strategic Network Solutions, Inc.
      www.certified-labs.com

      Comment


      • #4
        They are not uploaded to a directory. They are uploaded to the attachment table in the database. This is why you need to make those changes to php.ini and my.cnf that I mentioned previously.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Still not working

          Originally posted by Steve Machol
          They are not uploaded to a directory. They are uploaded to the attachment table in the database. This is why you need to make those changes to php.ini and my.cnf that I mentioned previously.
          Steve,

          I did make the changes you suggested and rebooted the server. Still not able to post the thread if it has an attachment with the thread. If I remove the attachment from the thread it will post just fine then.

          Help.
          Christopher M. Heffner, CCIE, CCSI
          Strategic Network Solutions, Inc.
          www.certified-labs.com

          Comment


          • #6
            How large is the attachment and what is the contents of your my.cnf file?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Additional Details

              Steve,

              The file is 525kb in size. I have set the parameters to 5M in the my.cfg and in the php.ini

              Here is the contents of the my.cfg file for your review.

              [mysqld]
              datadir=/var/lib/mysql
              socket=/var/lib/mysql/mysql.sock
              set-variable=max_allowed_packet=5M
              [mysql.server]
              user=mysql
              basedir=/var/lib

              [safe_mysqld]
              err-log=/var/log/mysqld.log
              pid-file=/var/run/mysqld/mysqld.pid



              Thanks,
              Christopher M. Heffner, CCIE, CCSI
              Strategic Network Solutions, Inc.
              www.certified-labs.com

              Comment


              • #8
                And are you sure you allow file uploads of this size in the Admin CP 'Maximum File Size' setting?

                If so, fill out a support ticket at:

                http://www.vbulletin.com/members/support_form.php

                Be sure to include the login info to your Admin CP, phpMyAdmin and FTP.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X