Announcement

Collapse
No announcement yet.

PM pop-up message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PM pop-up message

    My users are complaining that they don't get the PM pop-up message when they have a new PM even though they have the option checked. I've installed some hacks ... so I was wondering if there is a specific code in any templates or global.php (or any file) that calls up and checks for the pop-up? Maybe it got deleted by accident. thanks

  • #2
    that has been happening on my forum too on occasion, not all the time, works most the time. I have most of my users trained now to use message tracking and if they notice a pm hasnt been read they usually will bump the pm with another then it works..

    I too have some hacks installed but dont know if one of them is the root cause or not and it's not a big deal for me as of yet. Couldnt be bothered trying to track it down so I am just waiting for vb3, I will be wiping out all hacks when it comes out and hope to solve the problem then.....


    Would be nice to find out what is causing it though.

    Comment


    • #3
      Did you notice it starting after upgrading to v2.3.0 perhaps? That's when it started with me ... except that was the time I installed a new skin from vbskins.com

      Comment


      • #4
        Do they have JavaScript enabled? The popup uses JavaScript.
        http://www.zelaron.com/sigs/rotsig.gif

        Comment


        • #5
          still running 2.2.9 and no javascript with any of my hacks

          Comment


          • #6
            He meant that the users need to have javascript enabled. They also need to wait for the page to completely load before the popup appears. If you have lots of graphicss or a slow-loading page, they may not be letting the page load.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Does $headnewpm In your headinclude template have anything to do with this?
              Ken Iovino
              Full Time PHP, Ruby and iOS Developer

              Comment


              • #8
                Originally posted by Steve Machol
                He meant that the users need to have javascript enabled. They also need to wait for the page to completely load before the popup appears. If you have lots of graphicss or a slow-loading page, they may not be letting the page load.
                I myself have experienced it and I do have javascript enabled as do others who have experienced it..for my forum its a rarity that it happens and is no big deal, Im on a fairly fast server with minimal other clients and load time is not a problem and no custom skin. I do have random images from my photopost gallery on the index but this problem with the pm has been around on my forum long before I even installed photopost..

                but all that said its not a big deal for me, when I upgrade to vb3 and the problem still persists then I will try and fix it. In many ways is a blessing, I can ignore peoples pms with a legitamate reason lol

                Comment


                • #9
                  Just checked ... it's not the skin. Seems to be happening to everyone

                  Comment


                  • #10
                    If it's happening to everyone and it's not the templates, then it has to be one of your hacks.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      would global.php be the file to look in?

                      Comment


                      • #12
                        You really should be asking this at vbulletin.org. There are a number of files that call this function.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Cool. I posted a link to here at vb.org. If it makes a difference, whenever I don't have a PM, the page loads normally. But when I have a new PM, at the bottom of the page, it says something like "page loaded, but with errors" I think the little yellow triangle is a javascript error?

                          Comment


                          • #14
                            This means your browser is either blocking or having trouble with the javascript.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              I have tracked the problem down!!!! hehe. I re-uploaded an un-editted version of index.php ... nothing happened. So I uploaded the modded one again. Then I uploaded an un-editted version of functions.php ... and viola! The pop-ups have returned. Now I just have to figure out what I messed up in functions.php

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X