Announcement

Collapse
No announcement yet.

database error on registration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • database error on registration

    I've recently installed a hack but also restored a backed-up data base and am now getting this error message via email

    "Database error in vBulletin 2.3.0:

    Invalid SQL:
    INSERT INTO useractivation
    (useractivationid, userid, dateline, activationid, type, usergroupid)
    VALUES
    (NULL, 287, 1053606951, '3010067', 0, 2)

    mysql error: Unknown column 'usergroupid' in 'field list'

    mysql error number: 1054

    Date: Thursday 22nd of May 2003 08:35:51 AM
    Script: http://www.canaryforum.com/forums/forums/register.php
    Referer: http://www.canaryforum.com/forums/register.php"

    Obviously the script has the word "forums" twice instead of just once from the referer but where do I fix that. I looked in register.php but couldn't find the work "forums". ???

  • #2
    Look through the Admin CP --> vBulletin Options --> [General Settings] --> URL Area.

    Are you using the database prior to you trying to install the hack, or after you made the changes you needed to make for the hack?

    I would try restoring your database.

    Comment


    • #3
      Originally posted by Cary
      Look through the Admin CP --> vBulletin Options --> [General Settings] --> URL Area.

      Are you using the database prior to you trying to install the hack, or after you made the changes you needed to make for the hack?

      I would try restoring your database.
      Hi,

      The URL info in general settings is fine. Looking at this part though

      "Invalid SQL:
      INSERT INTO useractivation
      (useractivationid, userid, dateline, activationid, type, usergroupid)
      VALUES
      (NULL, 288, 1053615917, '50889855', 0, 2)

      mysql error: Unknown column 'usergroupid' in 'field list'"

      I've restored all the user database info, ie user, useractivation, userfield, usergroup, usertitle - still no joy though, same database error.

      Comment


      • #4
        The problem is that the database you restored appears to be from an earlier version of vB and needs to be upgraded to vB 2.3.0. (The usergroupid field was added to the useractivation table in thwe 2.3.0 upgrade script.)

        What version of vB is this database from?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          The problem is that the database you restored appears to be from an earlier version of vB and needs to be upgraded to vB 2.3.0. (The usergroupid field was added to the useractivation table in thwe 2.3.0 upgrade script.)

          What version of vB is this database from?
          I was sure it was the same version 2.3.0 - the problem is I ran my forum on my works computer (which I left last week) and purchased my own license of vbulletin, installed it at home and just brought the mysql backup with me, none of the vb files. Can you help? I actually have the user files backed up separately if that'll be any use, I could send you them?

          Comment


          • #6
            Backup your current database, then rerun upgrade23.php again. This will add that field.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              Backup your current database, then rerun upgrade23.php again. This will add that field.
              Wheh-hey - thanks!!! It looks like that worked and i am back in business

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X