Announcement

Collapse
No announcement yet.

Dadabase Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dadabase Error

    I had this problem when installed my Vbulletin forum. It says as following:

    "There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience."

    I've editted the database username & password in config.php & da_mysql to fit my settings, but apparently, the databse ain't connecting. Anyone knows how to fix this problem? Thanks!

  • #2
    We need to see the entire error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Source:
      <!-- Database error in vBulletin :

      cannot use database vbulletin
      mysql error: Access denied for user: '[email protected]' to database 'vbulletin'

      mysql error number: 1044

      Date: Wednesday 21st of May 2003 04:42:23 PM
      Script: /*********/
      Referer:
      -->

      </table></td></tr></table></form>
      <blockquote><p>&nbsp;</p><p><b>There seems to have been a slight problem with the database.</b><br>
      Please try again by pressing the <a href="java script:window.location=window.location;">refresh</a> button in your browser.</p>An E-Mail has been dispatched to our <a href="mailto:[email protected]">Technical Staff</a>, who you can also contact if the problem persists.</p><p>We apologise for any inconvenience.</p></blockquote>
      Link of Vbulletin forum on my site: <URL Removed>
      Last edited by Cary; Wed 21 May '03, 3:03pm.

      Comment


      • #4
        Make sure all of the details in your config.php file are correct. One of the lines has incorrect information.

        Also, I removed the URL from your post because anybody who visited your site would've been able to see your password.

        Comment


        • #5
          Originally posted by Cary
          Make sure all of the details in your config.php file are correct. One of the lines has incorrect information.
          <?php
          /////////////////////////////////////////////////////////////
          // Please note that if you get any errors when connecting, //
          // that you will need to email your host as we cannot tell //
          // you what your specific values are supposed to be //
          /////////////////////////////////////////////////////////////

          // type of database running
          // (only mysql is supported at the moment)
          $dbservertype="mysql";

          // hostname or ip of server
          $servername="localhost";

          // username and password to log onto db server
          $dbusername="my-dbusername";
          $dbpassword="my-dbpassword";

          // name of database
          $dbname="vbulletin";

          // technical email address - any error messages will be emailed here
          $technicalemail = "[email protected]";

          // use persistant connections to the database
          // 0 = don't use
          // 1 = use
          $usepconnect = 0;

          // which users are allowed to view the admin log
          // separate each userid with a comma
          $canviewadminlog = "1";

          // which users are allowed to prune the admin log
          // separate each userid with a comma
          $canpruneadminlog = "a-name-here";
          ?>
          Above is codes of config.php file, and I have used my database name & password, but it still show the error (database error 1044) as in previous post. What could possibly be wrong??

          Comment


          • #6
            This error means either:

            1. One or more of the following is wrong in your config.php file:

            $dbusername
            $dbpassword
            $dbname

            If you are unsure of what the appropriate values are then you will need to ask your web host.

            2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X