Announcement

Collapse
No announcement yet.

new reply posting problem with 2.3.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • new reply posting problem with 2.3.0

    when users try to send an reply to an existing thread a blank page appears with no error message or anything else in it.

    i saw the same problem posted here, but with some 2.0.x. the solution that i saw was to deactivate email notifications. it works in this case too, but this is a feature i want to keep. so, is there another way to make new replies work while keeping email notifications enabled?

    i'm using vb 2.3.0 on Apache 1.3.27 / PHP 4.3.1 and the mail daemon is qmail.

    thanks,

    .costin

  • #2
    This sounds like a different problem. It's most like due to a hacked newreply.php file or changes in one of the New Posting Templates. Try going back to the originals of this file and those templates.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      the source is unchanged and it behaves exactly the same when i switch to the original template.

      strangely though, preview reply works ok, only submit reply only works when email notifications are disabled from the admin page.

      thank you,

      .costin

      Comment


      • #4
        If you have not installed any hacks, fill out a support ticket at:

        http://www.vbulletin.com/members/support_form.php

        Be sure to include the login info to your Admin CP and FTP.

        If you have installed hacks, then remove the hacks first before filling out the support request.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I just install the 2.3.0 and have the same problem.

          I dont install any hack..i turn off the Email features, and the problem still there.

          When someone go to reply, some post dont autorefresh..dont do the redirect...if you do a REFRESH, the post is there..but you have to refresh.

          Maybe is some bug whit the autorefresh template, i dont have new templates, just change all to original...but i cant make work.

          thank

          Comment


          • #6
            Well

            I install Apache 2.0.46 and the problem is gone...but now the apache2 consume much more resources.
            I have 0% idle of 2 cpus...
            But whith Apache 1.x the resources what fine, but have problem when i post...

            someone have the same problem..or can send me a COMPLETE config for Apache 1.x and another for Apache2..maybe i can stay whit the apache2 but whit a better config.

            Comment


            • #7
              I skipped the socket option at php configure, this was the problem at my installation. After I've added this option everything worked just fine. To recompile the php use first "make clean" to be sure that the new options are compiled.

              Here are the configure parameters for both apache 1.3.27 and php 4.3.2.:

              ./configure \
              --prefix=/www \
              --enable-module=so \
              --with-perl=/usr/bin/perl \
              --enable-module=expires \
              --enable-module=headers \
              --enable-module=log_agent \
              --enable-module=proxy \
              --enable-module=log_referer \
              --enable-module=rewrite \
              --enable-module=vhost_alias \
              --server-uid=www \
              --server-gid=wwwgroup

              ./configure' \
              '--with-pgsql' \
              '--with-mysql=/usr' \
              '--enable-shmop' \
              '--enable-sysvsem' \
              '--enable-sysvshm' \
              '--enable-sysvmsg' \
              '--enable-sockets' \
              '--with-apxs=/www/bin/apxs' \
              '--with-gd' \
              '--with-zlib' \
              '--with-zlib-dir=/usr/lib' \
              '--with-jpeg-dir=/usr/lib' \
              '--with-png-dir=/usr/lib' \
              '--with-gdbm=/usr/lib' \
              '--with-openssl=/usr' \
              '--with-xpm-dir=/usr/X11R6' \
              --disable-cgi \
              --with-bz2 \
              --enable-calendar \
              --with-dom \
              --with-dom-xslt \
              --enable-exif \
              --enable-ftp \
              --enable-gd-native-ttf \
              --enable-sigchild

              good luck,

              .costin

              Comment


              • #8
                Sorry but thank config are for apache or the first is for apache and the second for php?

                Pls writte the full install for apache and php..step by step

                i will reinstall and make is that work better...thanks!!..really, thanks

                Comment


                • #9
                  Yes, the first config is for apache, the second one for php.

                  You just have to run configure for apache, make and make install from the same place. Then configure php, make and make install and that's all, everything should work now.

                  .costin

                  Comment


                  • #10
                    Costing, can you post your Apache and MySQL config.
                    The complet httpd.conf and my.cnf...i like to take a lot, maybe i have some parametres out of range.

                    Thanks a lot!


                    .CeRe

                    Comment


                    • #11
                      1. httpd.conf has nothing to do with php, at most you should look at php.ini

                      2. i didn't change anything important in any php.ini or my.cnf. actually i didn't even touch my.cnf. in php.ini I've just changed the default email address and some other minor stuff. but it was already working when i changed this stuff, it should work for you too, with the default configuration.

                      try this : write
                      PHP Code:
                      <?phpinfo();?>
                      in some php file and see if it works, if this works and the forum doesn't you should look in apache's log files, error_log in particular, to see what was the error. In my case mail() function was not linked in the libphp because socket support was not activated at configure.

                      also, before any ./configure ... be sure to run make clean, or, to make sure everything is clean, delete your php sources and decompress the tar.gz and then try again to compile the beast.

                      if it's possible please let a php with phpinfo() so i can examine your settings, maybe i can see what's wrong ...

                      .costin

                      Originally posted by cerebro
                      Costing, can you post your Apache and MySQL config.
                      The complet httpd.conf and my.cnf...i like to take a lot, maybe i have some parametres out of range.

                      Thanks a lot!


                      .CeRe

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X